05 sebring coupe cruise control problems - Chrysler Forum - Chrysler Enthusiast Forums

Go Back   Chrysler Forum - Chrysler Enthusiast Forums > Chrysler Vehicles > Chrysler 200 & Sebring
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-24-2009, 10:55 PM
Junior Member
 
Join Date: Jun 2009
Posts: 2
Default 05 sebring coupe cruise control problems

I bought a 2005 sebring coupe about a year ago never really needed to use the cruise till now and i go to use it and the light comes on in the dash but when i try to hold the thing down to set it at a speed it does not stick to the speed it doesnt work and i cant figure out what it would be i checked the fuse it was good i checked just the 7.5 amp but idk if there are other fuses that link to that but i was wondering if it could be a vaccum hose or maybe a cruise sensor or something?


Could someone please help me out the dealership wants 100 bucks just to diagnois it
Reply With Quote
  #2  
Old 06-25-2009, 10:57 AM
dcotter0579's Avatar
Senior Member
2002 Chrysler Sebring
My Garage
 
Join Date: May 2008
Location: Detroit suburb
Posts: 3,787
Default

Make sure you are not driving with one foot on the brake pedal. Some people do that. The system is designed to kick out if the brake pedal is touched.
There is a vacuum servo that is connected to the throttle body to control the power to maintain speed. Take a look at that to make sure it's properly connected mechanically and to the vacuum supply.
The engine computer controls the cruise control. It takes input from the multifunction switch in the car and from the tranmission output speed sensor to process and then control the vehicle speed by means of the servo mentioned above. If there was a problem with the speed sensor you'd have transmission problems, so you can probably rule that out.
Reply With Quote
  #3  
Old 12-22-2010, 12:40 PM
Junior Member
 
Join Date: Dec 2010
Posts: 2
Default

I just purchased a 2005 Sebring Sedan. I am a big fan of cruise control and as I was driving it home I tried to engage the cruise control. The first time it stayed on for about 2 minutes before turning off. I couldn't get it to switch on again until I stopped, turned the engine off and the back on. Again, after 2 minutes the cruise control turned off and I couldn't turn it back on. Any ideas?
Reply With Quote
 
 
 
Reply



Tags
05, 2000, 2005, chrysler, control, coupe, cruise, engage, fix, forum, hose, pacifica, problems, sebring, vaccum, vacuum

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
98 breeze cruise control problems bikerdude8730 General Tech 3 07-05-2013 09:10 AM
"CRUISE" lights up for only one second before it goes out- cruise not working carsoftampabay Cirrus & Breeze 1 10-26-2012 11:31 PM
07 Sebring Cruise Control Problem tbcaddy18 Chrysler 200 & Sebring 2 07-25-2012 10:29 PM
07 Sebring cruise control not working Meethuk Chrysler 200 & Sebring 1 02-03-2012 12:33 PM
Cruise Control Problems SandJ Chrysler 300, 300C & 300C SRT-8 1 03-07-2008 12:28 PM

Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 07:06 AM.

Internet Brands, Inc.


Emails Backup