90 lebaron - Chrysler Forum - Chrysler Enthusiast Forums


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-10-2014, 04:40 PM
Junior Member
Thread Starter
 
Join Date: May 2014
Posts: 1
Exclamation 90 lebaron

I bought a 90 chrysler lebaron 2d. the digital display doesnt light up. the seatbelt light comes on when first firing up the engine then turns off after about 10 seconds. i had never been able to get the guages to light up. 2 nights ago, i went to move my car and the display came on, but was dimming in and out. most of the brightness was coming from the center outwards.. i noticed that the more gas i gave it, the brighter it got, so i took it for a short drive where i could floor it.. i managed to get the whole dash, clear the the corners, to light up for about 3 seconds. when i let the power die down in the engine, it dimmed back to bare minimum in the center, dimming in and out again... havent gotten it to light up since..
checked all fuses, all are good. not sure what would be causing this.. any ideas?
id love to have a spedometer lol
Reply With Quote
  #2  
Old 01-02-2015, 09:35 AM
Junior Member
 
Join Date: Dec 2013
Location: Fort Worth Texas
Posts: 7
Default

I once had a 1989 Olds Ninety Eight with exactly the same problem. So, also not knowing what devil was going on, bought a replacement at salvage yard. Ended up the Olds instrument cluster is in two parts. The illumination section and the gauges. It was the illumination section that went out. Recall how home fluorescents work? Same idea. The Olds illumination part is essentially the same thing. A ballast and lighting section. I swapped sections and got original gauges back on.. Which let me retain the original mileage reading. I pass this along a tad late likely? Sorry. Not on very often.

I know an Olds is not a Chrysler. But tech is often common. Your gauges likely operate in a similar manner of tech. Replace ballast section and I bet it works.
Reply With Quote
  #3  
Old 06-10-2015, 08:25 AM
Junior Member
 
Join Date: May 2015
Posts: 29
Default

4374384 is the part #....1990 Lebaron (1 year only). I have 3 of them used and untested.
mkolner14@hotmail.com
Reply With Quote
  #4  
Old 09-05-2016, 03:55 PM
Junior Member
 
Join Date: Sep 2016
Location: Snellville, GA
Posts: 4
Default

Hi!
I just repaired a 1993 LeBaron digital dash that had issues with the turn signals,headlights, and problems with the guages like yours.
I removed the dash fascia and a few screws and then extracted the dash digital
display module.
I then used a 30Watt grounded tip soldering iron and reflowed/resoldered all of
the solder joints on the module.
I would wrap the module in Aluminum foil when you remove it to keep any static
discharge damage to a minimum. You can use the Alumiinum foil as a work surface
that will provide some static discharge protection while resoldering the module.

After a head full of rosin core solder fumes for 4-hours, I had a fully functional digital
display again.
Regards, and POR - Press On Regardless
Bob
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
92 Lebaron convertible top problems!! randyuspsa Other 3 08-07-2008 01:25 AM
1990 Lebaron charging problems drwalker88 Other 0 07-07-2005 03:40 AM
’91 LeBaron conv. with pimped out interior FOR SALE atikovi PRIVATE For Sale / Trade Classifieds 1 06-02-2005 05:10 PM
MOVED: 92 Lebaron convertible top problems!! randyuspsa Off Topic 0 05-19-2005 08:40 AM
86 lebaron tps electrocuda K-Cars 1 04-21-2005 07:06 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:01 AM.