Go Back   Chrysler Forum - Chrysler Enthusiast Forums > Chrysler Vehicles > Chrysler Voyager & Town & Country
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Chrysler Forum - Chrysler Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-22-2009, 09:50 AM
Junior Member
 
Join Date: Jul 2009
Posts: 1
Default 1998 Town and Country Gauge Cluster Problems

I bought a 1998 T&C with the gauge cluster is out. Absolutely none of the gauges work, no mileage, and no shift selector LCD. The only thing that works on the dash is the lights when you turn the lights on. Another thing is the horn does not work when locking using the remote, but the horn does work with the horn switch in the steering wheel. I do notice the temp and gas gauges do jump about 1/4 of an inch when turning the key to the first two possitions but that is the only life out of any gauges. Here is what I have done to no avail:

>Replaced with WORKING dash - still no gauges, no mileage, or shifter LCD.
>Did the dash test by pressing trip and reset while turining key to "ON" - nothing happens, no codes.
>Disconnected battery for 2 minutes - still same problems
>pulled iod fuse - still same problems
>checked fuses - did not see any that were blown.

What can I do to test this? Does anyone have the wireing diagram for the gauge cluster? I would like to test the plug terminals that directly go into the dash, does anyone know how to do that?

Thanks in advanced.
This ad is not displayed to registered members.
Register your free account today and become a member on ChryslerForum!
Reply With Quote
  #2  
Old 08-12-2009, 08:05 PM
Junior Member
 
Join Date: Aug 2009
Posts: 2
Unhappy

Quote:
Originally Posted by running_swift@hotmail.com View Post
I bought a 1998 T&C with the gauge cluster is out. Absolutely none of the gauges work, no mileage, and no shift selector LCD. The only thing that works on the dash is the lights when you turn the lights on. Another thing is the horn does not work when locking using the remote, but the horn does work with the horn switch in the steering wheel. I do notice the temp and gas gauges do jump about 1/4 of an inch when turning the key to the first two possitions but that is the only life out of any gauges. Here is what I have done to no avail:

>Replaced with WORKING dash - still no gauges, no mileage, or shifter LCD.
>Did the dash test by pressing trip and reset while turining key to "ON" - nothing happens, no codes.
>Disconnected battery for 2 minutes - still same problems
>pulled iod fuse - still same problems
>checked fuses - did not see any that were blown.

What can I do to test this? Does anyone have the wireing diagram for the gauge cluster? I would like to test the plug terminals that directly go into the dash, does anyone know how to do that?

Thanks in advanced.
Same problem as mine..Grand Vogagers LE 3.8L...Visited many repair could not find out what problem...ABS light one all time...
Any one help please. Thanks Advance
Reply With Quote
  #3  
Old 08-13-2009, 01:49 PM
Senior Member
 
Join Date: May 2008
Location: England
Posts: 541
Default

Hi
Disconnect the heater panel 21 pin plug and see then. look for burning on that plug.
Reply With Quote
  #4  
Old 08-14-2009, 05:35 PM
Junior Member
 
Join Date: Aug 2009
Posts: 2
Default

Thanks your reply
I will do check as your advice...and and will let you know result
Reply With Quote
Old 08-14-2009, 05:35 PM
 
 
 
Reply



Tags
1998, 2000, chrysler, country, dash, fuse, gauges, guages, iod, jumping, lights, problems, tc, town, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 01:23 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup