1975 Chrysler imperial - Chrysler Forum - Chrysler Enthusiast Forums

300M, Concorde, LHS, New Yorker Discuss the Chrysler LH platform cars within.

1975 Chrysler imperial

Reply

 
 
 
  #1  
Old 02-23-2018, 01:34 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 5
Default 1975 Chrysler imperial

Hi guys brand new to the site Iv got a 1975 Chrysler Imperial Le Baron ok so far so good question there are two cables (mechanical) one runs from gearbox to a unit another runs from the unit to the back of the speedo this unit is attached to the cruise control .. so the gear box turns the cable turns that translate to a gear turning in this unit whatever its called, and in turn that rotates the second or maybe the upper cable so activate the speedo dial needle What is the thing /unit the two cables enter and exit from called Thank you
 
Reply With Quote
  #2  
Old 02-23-2018, 01:46 PM
Senior Member
Join Date: Jul 2017
Location: Western NY
Posts: 573
Default

Welcome, and my brining in an antiquity!A NICE ride in their day.
Been so long now since seeing that era of car, that I can't recall the proper (part ordering name) just remember calling it the cruise control "head". Something I never saw go bad, but saw lots of cables for them break inside the sheathing.
 
Reply With Quote
  #3  
Old 02-23-2018, 02:24 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 5
Default

Thanks Ill see if in the past anybody ever posted on Google a name or picture of the said HEAD thing how do I post a photo
 
Reply With Quote
  #4  
Old 02-23-2018, 02:30 PM
Senior Member
Join Date: Jul 2017
Location: Western NY
Posts: 573
Default

IF you examine it closely you should find a part # stamped on it, you could then use that to help in a Google search for it. Just what is the reason of your query?Does the CC not operate?
 
Reply With Quote
  #5  
Old 02-23-2018, 02:40 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 5
Default

Im not sur eit does at this time I have been dealing with other issues and as their fixed I thought Id examine the thing after removing the cables from the thing I checked it was rotating and it was so I then pulled the gearbox inner cable out all the way to see if it had broken down the line ,it had not so replaced that one tried to remove the upper cable I think its called from the seedo unit thast wont come out as its fixed in place by design however the end I could see looked fine and gears in the thing are rotating so there can not be a break in the upper cable as it would pull out when asked to .so im after double checking the thing so i can be sure of its integrity.
 
Reply With Quote
  #6  
Old 02-23-2018, 03:00 PM
Senior Member
Join Date: Jul 2017
Location: Western NY
Posts: 573
Default

From what you are describing, I would remove and check the speedometer drive gear down on the transmission that the one cable is hooked up to. That gear is known to wear out and stop any reading of the speedometer or cruise control function. Be careful on that part as they are usually color coded for final gearing ratio for speedo accuracy, someone may have install the wrong PLASTIC drive gear.

EDIT: I see that you are across the pond from me...Is this the same as a North American model?
 

Last edited by REBEL59; 02-23-2018 at 03:11 PM.
Reply With Quote
  #7  
Old 02-23-2018, 03:40 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 5
Default

 
Reply With Quote
  #8  
Old 02-23-2018, 03:43 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 5
Default

its on the bottom right of photo attached with the cruise control.yes its north american model .. and im after knowing what the unit is called so i can see how the two gears inside work and check the cables at both ends to see which i need to replace either upper cable or lower cable .
 
Reply With Quote
  #9  
Old 02-23-2018, 03:59 PM
Senior Member
Join Date: Jul 2017
Location: Western NY
Posts: 573
Default

That is a pic of your actual ride?...Man that is beautiful!
So that I understand correct. The cable from the gearbox(transmission spins when car is put in gear and driven, but speedo does not show speed? OR is it that CC just does not work?
Try looking for it with the words cruise control SERVO MOTOR
IF just cruise is not working, there is a vacuum diaphragm That the throttle cable hooks onto inside that big plastic end, and I have seen those break or that diaphragm tear and cause no cruise control problem. it will not affect speedo reading though.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Carlover
New Member Area
0
03-30-2017 12:50 AM
Mopar1960
Other
1
02-14-2017 08:47 PM
JP Roberts
Past Chrysler Models
0
02-15-2008 03:08 PM
chargerlady
PRIVATE For Sale / Trade Classifieds
1
12-31-2006 12:19 AM
luckeybuttons
PRIVATE For Sale / Trade Classifieds
0
12-29-2006 07:48 PM


Thread Tools
Search this Thread
Quick Reply: 1975 Chrysler imperial


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.