Chrysler 300, 300C & 300C SRT-8 The flagship of the Chrysler lineup offers the driver every bit of class of any European luxury sedan, combined with the availability of the Hemi, the engine which dominated the American Muscle Car Era

2014 Chyrsler 300C weird dash light issues

  #1  
Old 07-18-2014, 11:59 PM
Junior Member
Thread Starter
Join Date: Jul 2014
Posts: 2
Default 2014 Chyrsler 300C weird dash light issues

We have a 2014 300C that began have strange dash light issues at less than 200 miles on the car. The list of things occuring:

1. Minor bump in the road resulted in dash lights going out or some dimmed to barely visible including U-Connect screen. Adjusting brightness with variable resistor on dash resulted in no change. After 3rd occurrence took to dealer. Unable to find cause. The dash lights return to normal after engine restart.

2. At a bit over 3,000 miles the dash lights began doing the same as above when wipers activated only now the shifter lights go dark as well. Turn wipers off and things return to normal. Occasionally a slight bump in the road surface still blanks the dash lights.

3. At times with the dash lights go out the rear speakers appear to cease working. The car has the Harman-Karden 19 speaker system.

Our 2012 Ram 2500 has the same issue with the wipers being activated and it is just basic truck without U-Connect. Doesn't even have power windows or door locks.

We've had both vehicles into the dealer more than once over these issues and they have no solution and appear to not be getting any support from Chrysler in finding the cause of the problem.

Has anyone else experienced anything like this with their Chrysler vehicle? We're about to take the Lemon Law claim route on both.


 
  #2  
Old 07-21-2016, 09:27 PM
Junior Member
Join Date: Jul 2016
Posts: 11
Default

apparently chrysler has cheaped out on electronics and wiring/connectors. I just found a bad blind spot detector (damaged by non water tight connector) on my 14 T&C. Paid extra for all the extras and now im regretting it. Sounds like you got a loose connection or something in the TIPM like a connector or soldering connection loose.Look up TIPM issues for your models and see if you have any of the similar issues
 
  #3  
Old 07-22-2016, 06:11 AM
Member
Join Date: Dec 2015
Location: Cypress, TX
Posts: 58
Default

brought back a 2+ year old thread.
 
  #4  
Old 07-22-2016, 09:52 AM
Junior Member
Thread Starter
Join Date: Jul 2014
Posts: 2
Default

Originally Posted by adamrich33 View Post
apparently chrysler has cheaped out on electronics and wiring/connectors. I just found a bad blind spot detector (damaged by non water tight connector) on my 14 T&C. Paid extra for all the extras and now im regretting it. Sounds like you got a loose connection or something in the TIPM like a connector or soldering connection loose.Look up TIPM issues for your models and see if you have any of the similar issues
It's a software issue. The car has been to the dealer many times and neither they or Chrysler's tech guys have been able to correct. As being an old programmer they may never find the problem because of two different computer systems apparently having issues. Hoping the software update due to shifter problem recall will fix it.

On the other hand your analysis of connectors may well be correct. As a collector of vintage cars owning several brands the makes that typically have that issue come from GM, although I have noticed there have been production years of other makes that indicate they may have mistakenly hired an engineer from GM to be involved with wiring. Mid to late 1980's Lincoln Mark VII's are a good example.

The solution will likely be our going back to Lincolns if and when they finally produce their Bentley look a like. Shame because otherwise the car has been decent aside from a bit harsh ride thanks to the low profile tires.
 
  #5  
Old 07-22-2016, 10:04 AM
Member
Join Date: Dec 2015
Location: Cypress, TX
Posts: 58
Default

Originally Posted by OldMarine View Post
aside from a bit harsh ride thanks to the low profile tires.
I agree with my 300s as well. The car has 18k miles on it now and I'm on my 3rd set of these low profile tires from different manufacturers and after over $2500 spent on changing perfectly good tires, the end result is still a noisy and rougher ride than I ever expected from a pseudo luxury car.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fastfish
General Tech
0
03-03-2013 07:35 AM
fastfish
General Tech
0
03-03-2013 07:33 AM
missangeladjones
Chrysler 200 & Sebring
3
11-02-2007 11:19 AM
andypandy22a
Chrysler 200 & Sebring
0
03-06-2006 10:43 PM
2004LX
PRIVATE For Sale / Trade Classifieds
2
09-01-2005 11:31 PM


Thread Tools
Search this Thread
Quick Reply: 2014 Chyrsler 300C weird dash light issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.