Chrysler 300, 300C & 300C SRT-8 The flagship of the Chrysler lineup offers the driver every bit of class of any European luxury sedan, combined with the availability of the Hemi, the engine which dominated the American Muscle Car Era

Aftermarket HID issue...

  #1  
Old 03-08-2016, 02:34 PM
Junior Member
Thread Starter
Join Date: Mar 2016
Location: NH
Posts: 1
Default Aftermarket HID issue...

I have a 2006 300c without factory HID's. I've done some searching, but to no avail. Anyway, I tried installing an aftermarket HID kit and the lights only work when the car is off. I'm not using relay(s) or any kind of resistor either. The brand is Kensun, and I've had good luck with them in my Mustang and Dakota. Any thoughts? Thanks.
 
  #2  
Old 03-09-2016, 06:27 AM
Member
Join Date: Dec 2015
Location: Cypress, TX
Posts: 58
Default

your ballasts are putting out too low of a voltage for the FCM (front control module). FCM thinks it's a short so kills that circuit to prevent any further electrical damage back to the vehicle.

you need to use the appropriate relay kit for your light kit to power your ballasts directly from the battery.

nature of the beast with the 300 vehicles.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
thefabe1
Chrysler 300, 300C & 300C SRT-8
1
02-23-2015 03:31 PM
nitrox28
Chrysler 300, 300C & 300C SRT-8
4
05-09-2011 01:34 PM
sonic gihad
Chrysler Pacifica
2
01-27-2009 08:29 AM
hambone
Chrysler Pacifica
1
09-02-2008 12:57 AM
fdfever
Exterior
0
04-23-2007 02:29 AM


Thread Tools
Search this Thread
Quick Reply: Aftermarket HID issue...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.