Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

Bad starting 2.8crd

  #1  
Old 12-21-2011, 04:14 PM
Junior Member
Thread Starter
Join Date: Mar 2011
Posts: 7
Default Bad starting 2.8crd

Hi all I have a problem starting my 2.8crd voyager in the morning
it cranks over 8 or 10 times befor starting then when it starts
it is vere rough missing for 20 seconds, some times some times
smokes of a few seconds. I have taken it back to the garage that I got
It from who tell me they have replaced the egr valve,fuel presher regulator
& now the injectors but it still starts bad, as I am coming to the
End of my warranty I have 1 chance to get then to sort it
Any help would be brill
Thank mark
 
  #2  
Old 12-22-2011, 07:50 AM
voyager_dan's Avatar
Senior Member
Join Date: Sep 2009
Posts: 141
Default

if you are only having issues from cold then it will be the glow plugs
 
  #3  
Old 12-22-2011, 02:15 PM
Senior Member
Join Date: Dec 2009
Posts: 256
Default

Sounds like none of the glow plugs are working. Check the Glow plug relay.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fragmented
Chrysler Voyager & Town & Country
34
12-03-2014 08:55 AM
THEBUS
Chrysler Voyager & Town & Country
7
01-27-2014 01:23 PM
Nick1981-1
Chrysler Voyager & Town & Country
6
08-19-2013 05:27 PM
jtminnc
Chrysler Voyager & Town & Country
0
10-31-2010 07:08 PM
HrabiaMol
Chrysler Voyager & Town & Country
3
05-11-2010 08:40 AM


Thread Tools
Search this Thread
Quick Reply: Bad starting 2.8crd


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.