Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

cluster panel not working

  #1  
Old 10-05-2009, 02:25 PM
Junior Member
Thread Starter
Join Date: Oct 2009
Posts: 1
Default cluster panel,no park or stop lights working.

i have a 06 t&c my gauges went out i have no parking lights no emergency lights, no signal, break light, also not mileage led. when i open the slideing door the emergency lights dont go on either. also when i put the key in the ignition the chime dosent go on the power locks don't work. but when i take the key out the powerlocks work. all the fuses r fine and i switched the relays around i also took the battery cable off to reset computer. can someone help im stuck.
 

Last edited by fireeater91; 10-05-2009 at 06:28 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rollinsr99
Chrysler 200 & Sebring
15
12-03-2014 02:33 PM
fhadso
Chrysler 200 & Sebring
3
10-01-2013 07:37 AM
dwstoick
Chrysler Voyager & Town & Country
0
03-16-2013 12:13 AM
Brian0514
New Member Area
0
12-07-2010 10:34 AM
dieseln
Chrysler Voyager & Town & Country
4
08-26-2010 05:04 PM


Thread Tools
Search this Thread
Quick Reply: cluster panel not working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.