Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

Dash light Town & Country -99

  #1  
Old 03-14-2007, 07:25 PM
Thread Starter
Join Date: Mar 2007
Posts: 6
Default Dash light Town & Country -99

Hello

I have this problem the dash light is "dead". It started to go on and off but now it's always off. Everything elseworks fine speedmeter and so on. Pleas help me so I dont have too use a torchto see my speed.

Regards, Anteman
 
  #2  
Old 03-14-2007, 09:02 PM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,114
Default RE: Dash light Town & Country -99

does any of the other lights work aka the radio the ac control head the over head the same lights that light up as u drive at night?
 
  #3  
Old 03-16-2007, 03:29 PM
Thread Starter
Join Date: Mar 2007
Posts: 6
Default RE: Dash light Town & Country -99

it's only the lamps for driver info that are dead. eg. the ones behind the stearingwheel.

must thank you for the fast replay CRYSLER TECH i hope you have a cheap solution on my problem...

 
  #4  
Old 03-16-2007, 11:05 PM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,114
Default RE: Dash light Town & Country -99

well got 2 ideas First the more expensive route replace the printed ckt board and have some one program the guages when done or there are posts on here for a solder fix bight be for your issue not sure but seen it on here. If it was one bulb I would say replace the bulbs or all of them but if they all went out at the same time na board issue
 
  #5  
Old 04-01-2007, 12:11 PM
Thread Starter
Join Date: Mar 2007
Posts: 6
Default RE: Dash light Town & Country -99

how do i dismount the dashboard?
 
  #6  
Old 04-01-2007, 02:20 PM
Thread Starter
Join Date: Mar 2007
Posts: 6
Default RE: Dash light Town & Country -99

I don't think it i's a solding problem. The pins on the red socket have contact with the lamps (the + pin is a little bit burned). So I presume there is no power to the red socket. Can someone give me a hint how to procede the problemsolving?
 
  #7  
Old 04-01-2007, 03:37 PM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,114
Default RE: Dash light Town & Country -99

replace the ckt board and have a dealer or some one with a good enough computer to reprogram the insterment cluster
 
  #8  
Old 04-01-2007, 08:39 PM
Thread Starter
Join Date: Mar 2007
Posts: 6
Default RE: Dash light Town & Country -99

okay. but one thing bothers me. no 12Vone the pins in the redsocket, power to the 194 lamps("big ones"). it i's only teh 194 lamps that dont work. everything else works just fine. and one thing more there is no power on fuse #1 and 3 the one for the gauge lamps??
 
  #9  
Old 04-02-2007, 03:35 AM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,114
Default RE: Dash light Town & Country -99

check all the fuses then and get back to me
 
  #10  
Old 04-12-2007, 08:16 AM
Thread Starter
Join Date: Mar 2007
Posts: 6
Default RE: Dash light Town & Country -99



all fuses are ok.
 

Thread Tools
Search this Thread
Quick Reply: Dash light Town & Country -99


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.