1999 Chrysler Cirrus - acceleration problem

  #1  
Old 07-27-2008, 03:29 PM
Thread Starter
Join Date: Jul 2008
Posts: 3
Default 1999 Chrysler Cirrus - acceleration problem

I have a 1999 Cirrus LXi, after driving for about 20 miles, when the car is good an hot. The car begins to sputter when accelerating. It idles fine but, as soon as you press the accelerator, it sputters. Sometimes, it will stall. I have just replaced the cap and rotor because it would not start after rain. Now, it starts every time. I have tested the intake for a vaccum leak, none was found. Does anyone have a suggestion. Thank You.
 
  #2  
Old 10-08-2008, 02:18 PM
Join Date: Oct 2008
Posts: 3
Default RE: 1999 Chrysler Cirrus - acceleration problem

from reading this it sounds like you had the same problem I have now. Did you ever find out how to fix it?

Here's my plea for help on this forum:
https://www.chryslerforum.com/m_21120/tm.htm

 
  #3  
Old 10-10-2008, 08:05 AM
Thread Starter
Join Date: Jul 2008
Posts: 3
Default RE: 1999 Chrysler Cirrus - acceleration problem

My problem ended up being the distributor. I replaced the distributor and the problem has gone away.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Yates
Chrysler Aspen
0
10-11-2010 07:16 PM
Yates
General Tech
0
10-11-2010 07:02 PM
loxus
Cirrus & Breeze
0
11-06-2008 01:49 PM
americanap
300M, Concorde, LHS, New Yorker
0
05-13-2008 08:55 PM
Powerlifter626
PRIVATE For Sale / Trade Classifieds
0
02-14-2008 01:01 PM


Thread Tools
Search this Thread
Quick Reply: 1999 Chrysler Cirrus - acceleration problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.