2000 Chrysler Cirrus 2.4l n/a

  #1  
Old 10-21-2015, 10:51 PM
Junior Member
Thread Starter
Join Date: Oct 2015
Posts: 1
Default 2000 Chrysler Cirrus 2.4l n/a

First of all, I wanna thank everyone that visits this thread.

I recently bought a 2000 Chrysler*Cirrus. When i bought it, the vacuum hose connected to the heads was too short. Have not replaced yet but is sealed shut now. Was having idling issues. I drove the car home and it would constantly die anytime i needed to stop. I assumed it was the alternator or battery. Or both. Today i bought a refurbished alternator from AutoZone. Got that put in. It was a bitch trust me. (Note to anyone who has alternator problem: Have a 15mm ready. Keep WD40 close as hell.) Brought my battery to AutoZone so they could charge it and let me know if its an okay battery. From '11 so idk. This is the first car ive ever bought. I got a daughter on the way. This main idle isssue is my main priority to get fixed. Any pointers are appreciated greatly as to what else this could possibly be. Thanks,
KbTreez
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
teamweeeman
Street/Strip
3
04-12-2013 01:06 PM
TheLostAmish
General Tech
2
03-17-2009 06:41 PM
theharmfulspork
Cirrus & Breeze
4
10-10-2008 01:41 PM
chguy
Cirrus & Breeze
1
05-26-2008 01:13 PM
aznballa161
Cirrus & Breeze
0
01-08-2006 01:38 PM


Thread Tools
Search this Thread
Quick Reply: 2000 Chrysler Cirrus 2.4l n/a


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.