General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

02 jeep liberty no start

  #1  
Old 11-22-2007, 12:33 PM
Thread Starter
Join Date: Nov 2007
Posts: 2
Default 02 jeep liberty no start

i just put an engine in an 02 liberty that came out of an 04, i switched the obvious throttle body cam,crank, and oil pressure switch. the truck wont start and is giving me p0340 code no cam signal at pcm, one other thing the truck sat for 5 months with no battery does the pcm need to be reprogrammed??? it ran when it cam in it just ran on 5 cyl.[:@]any help would be great
 
  #2  
Old 11-23-2007, 10:33 AM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,115
Default RE: 02 jeep liberty no start

well i hope u liked putting that engine in because u have a lot more to do now. U installed an engine with a NGC computer and the 02 u have is a JTECH basicly they dont wok together 2 different systems as for as the wires and sensors are used. I really dont know if u can fix this or not with the engine u just put in. Thw wireharness is different the sensors are different the computer is different and once u get that stuff installed now u get to worry about the tranny which is different as far as the computers are the NGC has the tranny built into it and the JTEC has its own hehe all i can say is wow u did not do any research on this one did u?
 
  #3  
Old 11-23-2007, 08:17 PM
Thread Starter
Join Date: Nov 2007
Posts: 2
Default RE: 02 jeep liberty no start

everything hooked up fine,i did not change the computer any wiring harnesses or the tranny. i took the throttle body, cam sensor,crank sensor, and oil pressure switch out of the old motor and put them in the other motor because of the connector issues. the scanner is telling me p0340 no cam signal at pcm. the truck trys to fire but backfires through throttle body. if what you say is true i guess my other question is is the crank any different between the two motors that the crank maybe picking up the wrong signal???
 
  #4  
Old 11-23-2007, 09:20 PM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,115
Default RE: 02 jeep liberty no start

I sent an email
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
iceberg29
General Tech
1
08-18-2008 12:51 AM
jmbones
PRIVATE For Sale / Trade Classifieds
0
03-14-2008 08:45 AM
Midnight 85
Brand News, Concepts & Rumors
0
11-14-2006 06:27 AM
ViperGTS
Brand News, Concepts & Rumors
0
06-05-2006 05:15 PM
Midnight 85
Brand News, Concepts & Rumors
0
03-24-2006 01:56 PM


Thread Tools
Search this Thread
Quick Reply: 02 jeep liberty no start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.