2.4L rapping noise - Chrysler Forum - Chrysler Enthusiast Forums

General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

2.4L rapping noise

Reply

 
 
 
  #1  
Old 04-25-2018, 08:13 PM
Junior Member
Thread Starter
Join Date: Apr 2018
Posts: 1
Default 2.4L rapping noise

Hey all, hope I am posting this in the right place and also where it will be seen.

Trying to fix a problem with my sister n laws car. It's a 2007 PT non turbo with only 16,500 miles on it. She just inherited it from her dad. He bought it new and hardly ever drove it. She was told that he had taken it to a shop once for an oil leak but other than that we don't know much history on it.

It starts and runs smooth but has a pretty bad engine noise. When I heard it it was loud enough I thought it was a rod knock. I wondered if he hadn't ran it low on oil when it leaked and scored the bearings. I dropped the pan, balancer assembly and did inspection on the rod bearings. No apparent damage but one of them did seem to fall out of both sides of the rod easier than I thought it should. Bearings were cheap and I was there so I put in new rod bearing and bolts. BTW Miked the shaft and it was dead on on all 4. Reassembled it of course new oil and filter. The engine did run quieter but still had a pretty loud rapping to it.

The noise seems to go away after you rev past 2200 maybe 2500. Seems loudest at idle or slightly above. Not a ticking but more severe. Sounded louder on the right side but very hard to tell exactly where it is. So I pulled the intake and valve cover. Was no lash on any of the followers/rockers and I rotated it to several different points checking this. Cam looks fine. Pulled a cam cap on the pass side and no scoring or damage there either. So I removed the rockers inspected them. all looked and rolled fine. Pulled the lash adjusters and made a fixture for my drill press to put a load on them expecting to find one collapsing. No luck there. Soo I rolled the dice and put in a set of lash adjusters. Reassembled it and it's still the same no change in how it sounds.

I read a TSB about chamfering the cam caps because of interference but that was out in 2004 so I didn't expect it to be a problem in 2007 models. I am not new to engines but this is my first 2.4l repair. Does anyone have an idea what this could be or ever heard of something like this?
 
Reply With Quote
  #2  
Old 04-30-2018, 10:01 PM
Senior Member
Join Date: Mar 2018
Posts: 161
Default

That sounds a lot like what my 2004 Dodge Intrepid had. Ended up having to replace the engine.
I learned huge lesson with that car.
If you buy a used car and it comes with a warranty, ask them to print it on toilet paper if it does not include wear and tear coverage, so that you can get some use out of it.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bgeise
Chrysler Voyager & Town & Country
3
11-05-2014 03:38 PM
MOHAMMEDHU2003
Chrysler 300, 300C & 300C SRT-8
1
07-22-2005 04:51 AM


Thread Tools
Search this Thread
Quick Reply: 2.4L rapping noise


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.