General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Town & Country Radiator Fans Not Working

  #1  
Old 04-04-2008, 09:26 PM
Thread Starter
Join Date: Apr 2008
Posts: 1
Default Town & Country Radiator Fans Not Working

I'm helping my elderly retired neighbor work on his 1998 Chrysler Minivan. He recently damaged the engine when it overheated and he had to have the heads machined.

I know that the radiator fan relay, which is a solid state relay (SSR) that sits by itself bolted to the frame under the airbox, is often a problem. As far as I can tell there is no other like it on the vehicle to swap it with. Testings was done with the engine running (warm) and AC on where necessary. The check engine light is not on. Here is what we have done so far:

- checked fuse
- checked both fans by connecting the directly to 12v
- checked resistance on the coolant temp sending unit
- disconnected the CTSU to see if the fans would come on in emergency mode
- with one fan plug disconnected, 0v across plug (fans are wired in parallel)
- with both fans connected, 12v across either plug (fans are wired in parallel)
- 12v present at relay input
- continuity tests from fan plug to fan plug and fan plug to relay plug are good
- [ground] wire from fan plugs to engine ground reads good path to ground
- I tried to see if the relay plug was getting a signal from the Powertrain Control Unit (PCU) and didn't see anything but I'm not sure what to look for. I was expecting around 5vdc.
- no damage or corrosion at any plugs I've checked

I'm troubled as to why I'm getting 12vdc at the fans with the ignition off. The relay provides [fan out] and [ground] wires to the fan but according to the Haynes manual there is also a ground besides the one provided by the relay. If the relay always provides 12v to the fans but only provides a ground when activated, why is there another ground?

The relays are around $50 and the store will not take it back if they think it has been installed.

Anyone have any ideas?

Thanks





[IMG]local://upfiles/5448/83B34C1AD5AF4AEBB8F7A8B4D2B57CEC.jpg[/IMG]
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
FX-IT-FLX
Chrysler Pacifica
54
02-19-2017 12:24 PM
Gromit
Chrysler Voyager & Town & Country
19
08-15-2013 04:02 PM
cirrus98
Chrysler Pacifica
2
07-11-2013 08:59 PM
jammozzz
Chrysler Pacifica
9
04-20-2011 09:51 AM
red3737
Chrysler Voyager & Town & Country
5
02-19-2011 09:24 PM


Thread Tools
Search this Thread
Quick Reply: Town & Country Radiator Fans Not Working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.