New Member Area New to CF? Stop in tell us about you.

1999 chrysler voyager squealing

  #1  
Old 01-10-2019, 07:06 PM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 1
Default 1999 chrysler voyager squealing

Hi i have a 1999 chrysler voyager 3.3l petrol. When it is running and you accelerate its sqeals. We have replaced all bearings and pulleys. Replaced waterpump and alernator. When u start it its quiet but when u rev it up she squeals bad. Any solution wud be much appreciated.
 
  #2  
Old 01-10-2019, 07:33 PM
Senior Member
Join Date: Jul 2017
Location: Western NY
Posts: 812
Default

Welcome to the forum. You may be able to find out more about your minivan on the model specific Chrysler Voyager and Town & Country forum page.
Have you replaced the automatic tensioner itself, or just the pulley on the end of it? I've seen the spring tension unit in them weaken and allow for insufficient belt tension that would allow "squealing".
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
project260
300M, Concorde, LHS, New Yorker
2
05-05-2011 04:01 PM
bds0688
Chrysler 200 & Sebring
2
10-18-2010 12:45 PM
slyder04
Chrysler 200 & Sebring
2
10-15-2010 05:02 PM
amnapoli
Chrysler 200 & Sebring
8
04-22-2010 10:56 AM
phatboyfromla
300M, Concorde, LHS, New Yorker
5
04-09-2009 10:00 PM


Thread Tools
Search this Thread
Quick Reply: 1999 chrysler voyager squealing


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.