Other Any other Chrysler within.

93' Vision Horn not working

  #1  
Old 04-26-2011, 01:06 PM
Junior Member
Thread Starter
Join Date: Apr 2011
Posts: 1
Default 93' Vision Horn not working

Hello all,
This is my first post on the forum. I have a 93 Eagle Vision that the horn is intermittently working. I have checked all the usual suspects. The Horn relay, Horn itself, and switches are fine. The problem seems to be that the steering column is not grounded consistently. I if I remove the switch/airbag assembly and manually ground the steering column, horn works every time. I read somewhere the ground comes through the bearing and if its old and dirty this can break the continuity, is this true? Any suggestions on how to ground the steering column?

This is the only thing keeping me from passing inspection.

Thanks
Thomas
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
D-Day
Chrysler 200 & Sebring
12
07-09-2012 07:50 PM
sidhabo
300M, Concorde, LHS, New Yorker
0
08-21-2009 12:53 PM
Torancis_Chrysler
Chrysler Voyager & Town & Country
6
07-06-2009 01:44 PM
kartracer20
Chrysler Pacifica
4
03-26-2009 08:31 PM
greenblaze98
300M, Concorde, LHS, New Yorker
0
05-22-2008 03:32 PM


Thread Tools
Search this Thread
Quick Reply: 93' Vision Horn not working


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.