Other Any other Chrysler within.

Various Lebaron Problems...Need Help!

  #1  
Old 12-19-2006, 05:31 PM
Thread Starter
Join Date: Dec 2006
Posts: 1
Default Various Lebaron Problems...Need Help!

I recently bought a really nice 58k mile Chrysler Lebaron convertible. The car was very well cared for, but was sitting for quite awhile and now the car has some issues. This is where you come in.

1) The transmission is the bullet-proof Torqueflite 3-spd. auto. When shifting from any gear into Reverse, it shifts very hard and sounds awful making a loud CLUNK noise. I know it shouldn't shift as hard as it does because I've owned two past Chryslers with this same engine and transmission and they shifted into reverse much more smoothly. The transmission shifts perfect going down the road into all forward gears. The owners manualrecommends having the trans. fluid changed and bands adjusted every 15k miles.Will having these bands adjusted fix the hard Reverse shift?

2) Between 1500-2000rpm, there is an audible grinding metal noise that comes from the engine bay.It kind of sounds like a worn out bearing. I was told by amechanic that it could possibly beone of the pulleys wearing out, which is causing a belt to squeal too. Is this common and what is thereal problem to fix?

3) Onemorning, I turned my windshield wipers on and they worked fine for about 5 seconds, then began to make ametal clanking noise, resulting in the driver-side wiper arm stopping midway and the passenger-side wiper continuingto operate as normal. I disasembled the cowlpanel and foundtwo disconnected black metal rods lying inside.Thereare no broken pieces that I could find and nofasteners of any type to hold these pieces back in place as they should be. So how doI properly fix this and what parts should I need?

4) Lastly,both front seatsbacks are not locking in place as they should be. Withvery slight pressure, the front seatbacks flop forward without using the releaselever located on the lower, outboard sides of the front seatbacks. Both of these levers refuse to lift up likethey should, as if they are locked or frozen in place. Iremoved the plastic covers on both seat mechanisms and found no apparently damage,broken, or missing pieces. What the hell is going on here and how doI fix them so the seats lock in place like they should?


[IMG]local://upfiles/2274/FF37CB19EEEC40D2A08A8CF013A7A8A3.jpg[/IMG]
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
shmily1
Chrysler 200 & Sebring
0
10-30-2013 01:55 PM
antiflag22skate
General Tech
1
06-02-2011 07:48 PM
Mashashin
Past Chrysler Models
0
08-04-2008 03:09 PM
danielt33
Private 'Wanted' Classifieds
1
03-17-2008 12:20 AM
Crazykth
Other
2
05-08-2006 02:44 AM


Thread Tools
Search this Thread
Quick Reply: Various Lebaron Problems...Need Help!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.