1987 Fifth Avenue no power accelerating

  #1  
Old 09-24-2014, 01:17 PM
Junior Member
Thread Starter
Join Date: Sep 2014
Posts: 1
Default 1987 Fifth Avenue no power accelerating

Took the car in had the carburetor rebuilt, replaced gaskets hoses. it idles smooth and revs up great but no power with acceleration. Computer maybe? Could not find a rebuilt computer sent this one in... failed so bad would not rebuild. I did finally find one he put it in reworked carb some more but still no acceleration when you step it down. tested electronics everything seems to be working off of new computer. Any Ideas what else after over 3 months of this car sitting at his garage he gave up. He tried everything he and others could think of and only charged me for the original work and not all the other hours put in.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
leros10
Other
0
01-29-2012 06:35 PM
FifthAve1987
Private 'Wanted' Classifieds
2
12-17-2010 04:22 AM
glutferret
Past Chrysler Models
0
04-07-2008 09:18 PM
Spunka
Private 'Wanted' Classifieds
1
11-09-2006 07:46 PM
airforce
Other
4
05-22-2005 01:07 AM


Thread Tools
Search this Thread
Quick Reply: 1987 Fifth Avenue no power accelerating


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.