Losing all electronics? - Chrysler Forum - Chrysler Enthusiast Forums


Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-22-2016, 01:43 PM
Junior Member
Thread Starter
 
Join Date: Dec 2016
Posts: 1
Unhappy Losing all electronics?

Please help as I don't want to get ripped off when I take this 2004 Concorde to the mechanic. I bought the car a week ago! All worked fine. Then I lost the power windows. Then the radio.....then the power locks and god knows what else. The strangest thing....the windows will work for 3 seconds the minute you start the car then stop. The radio and power locks went a few days later. I plugged in a Bluetooth radio transmitter into the lighter (which really needs wiggling to work) when I got the car. Could that have something to do with messing up the electrical system?? Wipers are currently working. I also have a left headlight out but I don't think it's related! Any help is appreciated!
Thanks,
Lito
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Is Consumer Reports losing its sway? Are we all? Chrysler Forum Editor Brand News, Concepts & Rumors 2 11-04-2012 01:00 PM
Losing Coolant sjbilton Chrysler Voyager & Town & Country 0 04-07-2008 07:06 AM
Chrysler LHS losing coolant luckilori226@yahoo.c 300M, Concorde, LHS, New Yorker 7 06-21-2007 05:40 PM
MOVED: Chrysler LHS losing coolant luckilori226@yahoo.c New Member Area 0 06-20-2007 01:09 PM
American automakers losing in profit margin comparison Midnight 85 Brand News, Concepts & Rumors 0 10-05-2006 12:59 AM


Tags
concorde, electrical, locks, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:06 AM.