300M, Concorde, LHS, New Yorker Discuss the Chrysler LH platform cars within.

99 Chrysler 300m engine problems.

  #1  
Old 05-04-2015, 09:35 PM
Junior Member
Thread Starter
Join Date: May 2015
Posts: 2
Arrow 99 Chrysler 300m engine problems.

I have a 1999 Chrysler 300M that's been having problems and has gotten worse.

First off, the engine at idle runs abit wild. It'll go from 600RPM to about 2000RPM. I let it sit one day to see how high it will go on the RPMs and I let it get to about 3500 and I shut it off. It gradually got up that high and was continuing if I didn't stop it.

Secondly, While driving the RPMs will go up and down and the car will shift hard up and down. Sometimes it won't shift at all and just be stuck, it mainly does that in 1st gear. I will put it in the Manual position, so I can change the gears myself, but yet it changes on it own.

Thirdly, the lights flicker constantly but you can barely see it. You have to concentrate on the lights to really notice it. My wife found that out before I did.

Now I have been looking all over the internet for the past few days and haven't found really anything on what to do. Only thing I have found was to clean the IAC and/or change out the PCM.

I need help with this what are ya'lls thought on this?
 
  #2  
Old 05-04-2015, 10:01 PM
Junior Member
Thread Starter
Join Date: May 2015
Posts: 2
Default

Also, forgot to mention, that this is a 3.5L V6. it has 160k miles on it as well.
 
  #3  
Old 05-05-2015, 05:24 AM
Senior Member
Join Date: Sep 2012
Location: Somerset N.J.
Posts: 396
Default

Sounds like a vacuum leak. Search over at www.300mclub.org for help with your issues. Great site dedicated to 300M's
 
  #4  
Old 05-11-2015, 11:08 AM
Junior Member
Join Date: Jan 2015
Posts: 2
Default

I'm having the same problems as you are with my 1999 LHS 3.5L. It's an intermittent condition on mine. I've swapped out the IAC and the problem still exists. Removed and cleaned the throttle body. Still no fix. I just ordered a new Throttle Position Sensor and it should be here tomorrow. I'll let you know if it helps.
 
  #5  
Old 08-31-2015, 04:20 PM
Junior Member
Join Date: Jan 2015
Posts: 2
Default

Sorry for the late reply but i install the new Throttle Position Sensor and the problem is gone. I've got other things going on now but the surging idle is taken care of.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
2000_300m
300M, Concorde, LHS, New Yorker
3
04-24-2014 01:06 AM
supra92
300M, Concorde, LHS, New Yorker
2
01-21-2012 08:24 PM
jfyfe
General Tech
4
08-18-2010 07:43 PM
kristenrife2003
300M, Concorde, LHS, New Yorker
0
12-13-2007 09:52 PM
cwbritt
General Tech
1
08-17-2007 11:28 AM


Thread Tools
Search this Thread
Quick Reply: 99 Chrysler 300m engine problems.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.