Chrysler 200 & Sebring Whether it be the sedan, coupe, or convertible, this mid-sized model offers a touch of class to every style in it's lineup

Computer Reading "half-speed"

  #1  
Old 01-18-2010, 10:52 AM
Junior Member
Thread Starter
Join Date: Jan 2010
Posts: 4
Default Computer Reading "half-speed"

2004 Convert. 4 cyl.
I had to replace my battery and get a state inspection. I drove for about a week and everything reset in the computer (required for Mo. state inspection) with the exception of the cat and O2 sensors. I took it to a reputable shop and they said the computer only reads half of the vehicle speed. If I drive 60, the computer reads 30. So unless I drive 120mph for 5 minutes, I can't pass my inspection. The shop said both the speed sensors tested OK. They also believe the Cat and O2 sensors are OK. They just don't know why it's reading half-speed. Anyone have any ideas? I have no other history on the vehicle as I bought it used.
Thanks,
Ken
 
  #2  
Old 01-18-2010, 01:06 PM
dcotter0579's Avatar
Senior Member
Join Date: May 2008
Location: Detroit suburb
Posts: 4,993
Default

Does your speedometer on the dash read correctly? The signal that generates the information displayed on the dash comes from the same place. If the dash speed reads correctly, then the engine computer is reading and interpreting the information correctly.

For your information, the output speed sensor in the transmission generates a signal based on the rotation speed of the transmission output shaft. This signal is transmitted over a wiring harness to the tranmission control module. The TCM, in turn, transmits it to the engine control module. The engine control module uses the information but also transmits it to the body control module which displays it on the dash.

If the engine control module were reading half the speed, then so should your speedometer and I think you would notice that pretty easily.

If your speedo is reading correctly then it's time for another opinion. Find another shop.
 
  #3  
Old 01-18-2010, 02:47 PM
Junior Member
Thread Starter
Join Date: Jan 2010
Posts: 4
Default

The speedo works correctly. The first shop didn't have any 'up-to-date' diagnostic equipment. This shop was the one that told me about the 'half-speed' problem.
Thanks anyway....
Ken
 
  #4  
Old 02-11-2010, 10:02 PM
Junior Member
Join Date: Feb 2009
Posts: 3
Default

It sounds like they are BS'ing you.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
HowieF16
Chrysler Voyager & Town & Country
6
10-13-2014 03:49 PM
sebringshell
Chrysler 200 & Sebring
5
09-11-2011 05:57 PM
artvandelay
Chrysler 200 & Sebring
1
12-27-2008 11:27 AM
blong
Chrysler 200 & Sebring
1
03-31-2008 10:15 AM
trev0006
Off Topic
1
10-21-2007 12:59 AM


Thread Tools
Search this Thread
Quick Reply: Computer Reading "half-speed"


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.