Chrysler 300, 300C & 300C SRT-8 The flagship of the Chrysler lineup offers the driver every bit of class of any European luxury sedan, combined with the availability of the Hemi, the engine which dominated the American Muscle Car Era

2009 Chrysler 300 Limited (RWD): Transmission Slipping?

  #1  
Old 11-13-2017, 08:09 PM
Junior Member
Thread Starter
Join Date: Nov 2017
Posts: 2
Default 2009 Chrysler 300 Limited (RWD): Transmission Slipping?

Hello fellow Chrysler owners and enthusiasts. I'm new to the forum but thought this would be a good place to ask questions.

I purchased a 2009 Chrysler 300 Limited in May with around 164xxx km on it. It was in good shape and runs pretty well, but lately I've been having a problem with what I believe is the transmission.

When I cold start the vehicle after it's been sitting for a while, I'll throw the vehicle in drive and barely make it down the street before the vehicle stalls. The RPMs will be capped at 2000, and even with my foot to the floor on the gas pedal, the vehicle won't move, almost like it's stuck in neutral. Shifting into neutral and revving the vehicle for a little bit will eventually get it to jolt back over 3000 RPMs again and it'll be good to drive until the next cold start.

Could this potentially be related to low transmission fluid? Or if anyone else has had this issue before, what fixed it for you?

I've included a YouTube video here demonstrating the problem with the vehicle in Park: https://www.youtube.com/watch?v=lH2f...ature=youtu.be

Thanks in advance!
 
  #2  
Old 11-14-2017, 04:56 AM
Senior Member
Join Date: May 2013
Location: eustis, fl
Posts: 121
Default

I really can't say what your exact problem is but at 164,000 miles you are way overdue for a transmission fluid and filter change.
Given your symptoms the problem could well be "transmission" related. Were I you, I would start with a simple transmission service and go from there. Good luck and DO keep us posted.
 
  #3  
Old 11-17-2017, 01:20 PM
Junior Member
Thread Starter
Join Date: Nov 2017
Posts: 2
Default

Update: I tried checking the transmission oil with a clean engine oil dipstick and didn't see anything on it. I brought it into the dealership who confirmed there was almost no transmission fluid oil left. Refilling it has solved the issue.

Thanks tarhealcracker.
 
  #4  
Old 11-17-2017, 06:59 PM
Senior Member
Join Date: May 2013
Location: eustis, fl
Posts: 121
Default

Alls well that ends well. Thanks for the feedback.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Sonny Wallace
General Tech
1
09-10-2015 12:36 AM
feelingood789
General Tech
0
02-06-2014 07:34 AM
robertway
Chrysler Voyager & Town & Country
4
07-17-2011 01:18 PM
americanbulld27
Chrysler 300, 300C & 300C SRT-8
0
03-30-2008 08:54 AM
crissp
Chrysler 300, 300C & 300C SRT-8
1
04-15-2006 05:50 AM


Thread Tools
Search this Thread
Quick Reply: 2009 Chrysler 300 Limited (RWD): Transmission Slipping?


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.