Chrysler 300, 300C & 300C SRT-8 The flagship of the Chrysler lineup offers the driver every bit of class of any European luxury sedan, combined with the availability of the Hemi, the engine which dominated the American Muscle Car Era

bad wheel bearing?

  #1  
Old 06-27-2016, 03:14 AM
Junior Member
Thread Starter
Join Date: Jun 2016
Posts: 1
Default bad wheel bearing?

I have a 2005 chrysler 300, 3.5 L engine (RWD) I bought the car at 180,000 miles. I have had it for 2 years. Only put 24,000 miles on it. Within the last 1,000 miles I have replaced both front struts, both stabilizer links, both outer rods, and the right inner rod. A rotor on the front passenger side. I also put ceramic pads on and I still have a squeal. I'm down to caliper sticking or a bad wheel bearing.

Symptoms are: high pitched squealing when not breaking. Squealing is random...it literally comes and goes while braking, not braking, turning and not turning. My rotor had a deep groove in the back on passenger side. Replaced that and I'm still experiencing the same sounds after replacing brake pads 3 times within 10,000 miles. Maybe the caliper is sticking but I feel it is worse than that. It squeals so randomly it's hard to tell. It usually happens after a low left turn...it also happens when I'm not turning ( driving for minutes without braking) I could be going 55 for 2 minutes without braking and it randomly starts, only stops when slightly press on breaks. Sometimes goes away when I slam on brakes. It can't be rotors or pads...have also applied (stop brake squeal lol which was a joke) if you've had the same problems I would appreciate feed back. If you haven't than I pray you're a certified mechanic because I've had too many mechanics tell me multiple things only too spend thousands of dollars in a month to still hear the same sound. Also I just replaced rotors today and it made no difference in the squel, still same scenario and still the same sound. Makes me think it's bearings. What do you think?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JTS
Chrysler Pacifica
3
02-17-2015 07:26 AM
j dog
General Tech
15
09-22-2013 12:01 PM
simonda
Chrysler Voyager & Town & Country
0
11-17-2007 07:25 AM
petey1972
Chrysler 200 & Sebring
2
04-06-2007 01:28 AM
OldSchool
General Tech
4
01-28-2007 01:44 PM


Thread Tools
Search this Thread
Quick Reply: bad wheel bearing?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.