Chrysler Pacifica Luxury meets versatility in this mid-sized sport utility vehicle

05 chrysler pacifica touring awd questions

  #1  
Old 11-18-2017, 03:50 PM
Senior Member
Thread Starter
Join Date: Sep 2011
Posts: 121
Default 05 chrysler pacifica touring awd questions

i just got for my girl a 05 pacifica touring model 105k on it 3.5 and they said 6 sp transmission but i do not that for sure yet.

questions i have is there anything that these model have that i need to look for when they get to this point in mileage?

i noticed it has a clunking sound coming from the rt front area of the suspension when it hits bumps in the rod. the left side is ok. what should i look for? lower control arm dog bone for the sway bar tie rods ball joints?

it also has a warning about the tire pressure. my guess is either low tires or one of the wheel sensors are bad. so outside of inflating the tires can i turn off that warning or am i stuck until i install a new sensor? and if it is a sensor how do i determine what one is at fault?

and when i get in it and turn on the key it shows in the cluster something about error with a disk, i think it has something to do with the nav system. it goes out after you start to drive but can i turn that off so it will not show everytime i turn the key on?
and it came with one key can i just get a key for this car or is it one of those that needs to be programed to the car? thanks
 
  #2  
Old 11-19-2017, 04:25 PM
Senior Member
Thread Starter
Join Date: Sep 2011
Posts: 121
Default

ok for the clunking sound on my car being now one seems to know yet i found the right side sway bar mount was worn and the bar was moving and i think that is the issue on my car. the ball joints were good and the tie rods were tight and the dog bone was good so with the sway bar lose i believe it to be the cause. i will get a new one and replace it.

tire pressure was at 35 psi but i forgot the spare will do that tomorrow and see if the warning goes away. if not i may try getting new sensors and putting them in a pvc pipe and pressurizing it to 235 and see if the car see that and turns of the warning message.

found the nav disk and cleaned it but i still get the error so either the disk is bad or the nav head unit is bad, any ideas on that?


still waiting on the rest to be answered. bp
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sammittrue
Chrysler Pacifica
7
02-09-2016 09:47 PM
Stephane Parent
Chrysler Pacifica
6
09-16-2013 06:55 AM
thewayiseeit240
PRIVATE For Sale / Trade Classifieds
0
10-03-2012 12:33 PM
07RedPacificaT
Chrysler Pacifica
2
05-04-2010 09:38 AM
Midnight 85
Brand News, Concepts & Rumors
0
02-21-2006 09:56 AM


Thread Tools
Search this Thread
Quick Reply: 05 chrysler pacifica touring awd questions


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.