Chrysler PT Cruiser Offering a sedan and 2 door convertible, both of which offer a naturally aspirated or turbocharged engine, this car has something to offer everyone

2004 Cruiser (PT) Electrical problem

  #1  
Old 08-24-2018, 08:29 AM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 1
Default 2004 Cruiser (PT) Electrical problem

Hello.
Got myself a 2004 PT Cruiser 2.2 CRD (89kw)
It has this odd problem. When i take off the battery lead for about 30 minutes and reconnect battery, my Spedometer and interior lights and everything work. Sometimes for 5 minutes and sometimes for 2 hours. Then at random time my Spedo (whole instrument cluster), all interior light )expect the ones i can manually turn on and off not from steering column) stop working. I cant turn on interior light from the **** on steering column, no ding ding sound, no backlight of any buttons and ***** (rear wipers, heater and a/c ****) all is dark. And it stays like this. 3 weeks ago it was like this - while driving sometimes it went all out and came back. Now when it goes i have to pull off battery. Oh, and i noticed when the Instrument cluster goes dark the motor itself starts to work i bit rougher. idle is on normal speed but it starts shaking so bad my rear wiper is dancing around. BUT from positive side car starts to go faster It means lot of black smoke from muffler but it's like there is no turbo lag anymore. When Instrument panel is working then when i go flat on throttle it starts pulling about 1800rpm, but when IC is out and go flat on throttle it pulls right away no matter rpm. I had it under PC and MAP sensor reads fine even when IC is out.
I have changed out the ignition switch base. Cleaned the contacts of that switch and bent the contacts like suggested in other forums. Checked and cleaned Fuses in dash and under the hood. Have not tested relays.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
turbocruisin
PRIVATE For Sale / Trade Classifieds
6
03-16-2011 12:24 PM
guerdonm
General Tech
0
01-26-2010 02:24 PM
gmullen
300M, Concorde, LHS, New Yorker
2
04-26-2008 10:06 AM
ncallese
Chrysler 300, 300C & 300C SRT-8
1
01-12-2008 05:09 PM
ezcruisin
PRIVATE For Sale / Trade Classifieds
0
02-12-2006 04:47 PM


Thread Tools
Search this Thread
Quick Reply: 2004 Cruiser (PT) Electrical problem


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.