Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

01 town and country crazy dash light problems

  #1  
Old 10-31-2012, 01:06 PM
Junior Member
Thread Starter
Join Date: Oct 2012
Posts: 3
Default 01 town and country crazy dash light problems

I have a 01 town and country with 43k miles when you start it everything works fine, after driving it or if it sets for a few min. every light comes on the gauge cluster and check engine light and oil light also. Then the gauges go to zero and when you shut the engine off and pull the key out all these lights stay on you have to unplug the battery to reset everything any ideas thanks
 
  #2  
Old 11-01-2012, 12:51 AM
Senior Member
Join Date: Oct 2011
Location: California
Posts: 722
Default

Have you checked for codes? Sounds like the Body Control Module (BCM) or something related to the PCI data bus. Disconnecting the battery resets it. Try a shake test to induce or cure it. Have someone watch the dash with the engine running and shake the wire harnesses and connections at the IPM (fuse box) and tap on it. The BCM is tough to get at. It's on the firewall above and in front of the brake pedal. In the mean time you may be able to rest the data bus by pulling the IOD fuse for 2-3 minutes.
 

Last edited by Raptor 07; 11-01-2012 at 12:54 AM.
  #3  
Old 11-05-2012, 09:35 AM
Junior Member
Thread Starter
Join Date: Oct 2012
Posts: 3
Default

Originally Posted by Raptor 07 View Post
Have you checked for codes? Sounds like the Body Control Module (BCM) or something related to the PCI data bus. Disconnecting the battery resets it. Try a shake test to induce or cure it. Have someone watch the dash with the engine running and shake the wire harnesses and connections at the IPM (fuse box) and tap on it. The BCM is tough to get at. It's on the firewall above and in front of the brake pedal. In the mean time you may be able to rest the data bus by pulling the IOD fuse for 2-3 minutes.
Yes i had a diagnostic scan done and no codes on anything showed up, I will look for that IOD fuse and try that along with shake all wiring
 
  #4  
Old 11-05-2012, 01:01 PM
Junior Member
Thread Starter
Join Date: Oct 2012
Posts: 3
Default

Changed out the BCM with a new one still no improvment wiggled all the wiring also did nothing different. i also noticed the battery will drain to over a few days.
 
  #5  
Old 11-11-2012, 09:24 AM
Junior Member
Join Date: Nov 2012
Posts: 2
Default

Had the same problem with that, mine was on a 04 sebring 2.7 lxi though, but my postive wire for my alternator, was so loose I could move it around, try that maybe? My car still has issues, wreck on passenger cause constant high beams, when DRL fuse is in.
 
  #6  
Old 04-21-2014, 12:42 AM
Junior Member
Join Date: Apr 2014
Posts: 1
Talking 01 town and country crazy dash light problems

I had these same things happen with my 2001 T&C, but not anymore. First I was told a code indicated the alternator was fluctuating voltage and I replaced it, did not fix the problem. Another poster indicated a problem with his sliding door having a broken wire in the track at the base. I checked both sides and found nothing. Another poster said he found a bad sensor on the transmission, so I replaced both of them and didn't fix the problem. Another poster said he resoldered the pins on the back of the instrument cluster where the cars electrical plug goes on it. I checked them and found one suspect and did reheat the solder but it didn't fix the problem. I took it to an Auto Electric shop and they spent a full day on it and resoldered all 13 pins but it still didn't fix the problem. The shop looked like a brain surgeon working out of his basement so I took my car out of there. I figured I would throw some more parts at it myself and ordered an instrument cluster off ebay. When I put it in myself, the problem went away. Still good after about 60 miles and it used to go anywhere from 1 block to 8 miles and would light up every dash light. After about 15 seconds the gauges would drop to zero. But as I said, not anymore....YIPPEE.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TheAverageDan
Chrysler Voyager & Town & Country
7
06-02-2015 06:31 PM
cuda2000
Chrysler Voyager & Town & Country
16
01-14-2014 03:42 AM
Chrysler Forum Editor
Brand News, Concepts & Rumors
1
11-30-2012 04:26 PM
greenman
Chrysler Voyager & Town & Country
1
07-08-2010 02:14 PM
anteman
Chrysler Voyager & Town & Country
10
04-12-2007 12:31 PM


Thread Tools
Search this Thread
Quick Reply: 01 town and country crazy dash light problems


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.