Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

'06 Town & Country a/c issue...

  #1  
Old 06-28-2010, 07:38 PM
Junior Member
Thread Starter
Join Date: Nov 2009
Posts: 3
Default '06 Town & Country a/c issue...

My wife has an '06 T&C with just over 45,000 miles on it....needless to say it isnt abused!!! The air quit working about two weeks ago. It WAS as cold as a mother in laws heart....now hot air. Buddy of mine hooked his a/c guages up to the low side port, and checked it for vacuum. in 30 mins, no leaks. We rechaged it....took two of the smaller cans of 134 juice. air got cold for about 3 days..... thenl not cold. ac clutch kicks in (audible) and system draws down (lights dim ever so slightly..or flicker is better analogy)... all normal climate control functions okay. i checked the a/c blower fuse, and okay there, could it be the a/c relay? some omron relay? how do you check those? or do you just replace?
 
  #2  
Old 06-28-2010, 10:10 PM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,114
Default

if U had to add freon U have a leak wont be a relay issue so dont bother looking
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
NewTouringOwner2008
Chrysler Voyager & Town & Country
1
10-24-2014 12:15 PM
EWG
Chrysler Voyager & Town & Country
7
09-21-2013 08:16 PM
smishoe1
New Member Area
1
08-05-2013 10:34 AM
copprtop97
Chrysler Voyager & Town & Country
4
12-27-2012 07:01 PM
lwarren
General Tech
8
12-14-2012 12:54 PM


Thread Tools
Search this Thread
Quick Reply: '06 Town & Country a/c issue...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.