Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

98 voyager 3.3 (uk) heater problems

  #1  
Old 11-10-2009, 05:28 PM
Member
Thread Starter
Join Date: Oct 2009
Location: glasgow
Posts: 36
Default 98 voyager 3.3 (uk) heater problems

Hi folks, I have been looking through all old posts and though there are many about heater problems I have not really seen one taken through to any real conclusion. Anyway, maybe to you gurus out there this will be an easy one to fix. The heater in my car never really heats up that much. The heater blows ok but does not really blow hot air even at operating temp. The temp gauge reaches half way and the cooling fans can be heard coming on when needed and the car has never overheated as yet! Anyway the other week there was loads of steam coming out of the bonnet. I checked to find the radiator cap had loosened and steam blowing out of it. I re fitted the cap and topped up the coolant in the expansion tank and it has not been blowing steam since but I still have not got any proper heat in the car. I have seen loads and loads of stuff about diagnostics on this forum about running some sort of tests but dunno if that is what I need to do. All hoses seem to heat up no problems. I seen a post ages ago about flushing the coolant system and I can not find that thread again. From memory the person flushed the system and it still did not improve but then flushed again and it resolved the problem but that is from memory and I dunno it it was the coolant system or not. There was a cold snap here yesterday and the heater not working meant I had to scrape ice off the inside of the windscreen at that was at full operating temperature. Thank god the heated seats were working ok. when topping up I was led to believe that the expansion tank is where you topped up and not the radiator itself is that correct? Could it be that as the radiator cap was off that the system needs bled? Does starting the car on a gradient allow air blockages in the system come back to the expansion tank? any help would be appreciated as I don't really know where to start.

Thanks
Robert.
 
  #2  
Old 11-11-2009, 07:10 AM
H69's Avatar
H69
H69 is offline
Junior Member
Join Date: Nov 2009
Posts: 17
Default

Hi Robert
I am in the UK and have a '99 3.8 Canadian spec Grand Caravan.

What I have found with the coolant/heater system in mine is that it needs loads of flushing and bleeding to get it up to full operating temperature, and boy is it HOT when it's working (maybe Canuck spec is higher as I have a second heater matrix in the boot too )

I drained from the lowest point, flushed with clean water and top up both the rad and expansion tank over the course of a few days, keeping a close eye on levels until they level out and stop dropping between journeys - operating the heater from hot to cold and hot again repeated a few times through some hilly trips seems to bump the air out...

Hope this helps.

BTW - does your UK model have parking lights? I've put up a thread as I can't "find" any on mine...

P.S. - I currently know where there's a 3.3 in a UK scrappy if you need any bits
 
  #3  
Old 11-12-2009, 03:14 AM
Member
Thread Starter
Join Date: Oct 2009
Location: glasgow
Posts: 36
Default

Hi that's great thanks, I reckon I will always be looking for wee bits and peices for this car so any scrappy would be good. I will try the flush then and do as you describe and hopefully that will sort it, bloody cold at this point so any improvement would be good. About your parking lights, I will look at the thread but I am not aware of them in my car. I have a uk spec Grand LX model the one with rear air con and rear privacy glass and colour coded bumpers. I will check out the parking lights and let you know. Thanks again.
 
  #4  
Old 09-08-2010, 01:25 PM
Junior Member
Join Date: Jul 2010
Posts: 6
Default

I have a 2001/2 Crysler grand voyager crd does any body know where i can find the
speed pulse wire and its colour i want to fit a din fitting sat nav / radio unit
many thank for any help
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
maurerdrilling
Chrysler 200 & Sebring
20
01-15-2013 02:00 PM
skywalker
Chrysler Voyager & Town & Country
0
01-22-2011 08:19 AM
jr fan
General Tech
1
09-12-2008 03:03 PM
andrea1015
Chrysler Voyager & Town & Country
1
02-05-2007 11:13 AM
Scruffy
Chrysler Voyager & Town & Country
11
01-31-2007 11:32 AM


Thread Tools
Search this Thread
Quick Reply: 98 voyager 3.3 (uk) heater problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.