Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

Multiple issues...so lost

  #1  
Old 06-28-2012, 11:55 PM
Junior Member
Thread Starter
Join Date: Jun 2012
Posts: 3
Default Multiple issues...so lost

Thanks for reading and I'm sorry if I am reposting something.
I have a 2006 Town and Country 3.8L Touring Edition.

The problem started when we began to hear a slight knocking noise (from start while driving to finish, steady) and then it got very loud and very constant, worse when you first start. Stupidly, we continued to drive it and then it started stalling out whenever we came to a stop. Now it will not start at all.

Used an OBD reader, it threw one code: p0073, ambient air temperature sensor, which we cannot even find. We think it was knocked off while we were towing it. Even so, we are pretty sure this is not going to solve our problem.

Here is where we are at now: when we turn the key, we got electric power to the inside (lights, navigation, etc) but it doesn't even TRY to turn over.

Any ideas?
 
  #2  
Old 06-29-2012, 02:05 AM
TNtech's Avatar
Senior Member
Join Date: Jul 2010
Location: Tennessee
Posts: 1,234
Default

Sounds like you locked up the engine. Good news is they aren't that expensive compared to some. Try to turn the engine over by hand (with a big bar and socket)
 
  #3  
Old 06-29-2012, 09:26 AM
Junior Member
Thread Starter
Join Date: Jun 2012
Posts: 3
Default

Okay, I need to add some information/history:

The engine turns by hand, the starter was seized and has been replaced, two bearings (one over and one under) have been replaced, and the battery has been tested. It NEVER overheated and when we looked at the oil, even though it had recently been changed, it was bad.
 
  #4  
Old 07-05-2012, 07:42 PM
Junior Member
Thread Starter
Join Date: Jun 2012
Posts: 3
Default

Also, we replaced the bearings that were ruined: lower end, top and bottom.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
maagk
General Tech
3
10-02-2013 07:46 PM
patsysparks
Chrysler 200 & Sebring
1
06-14-2010 09:55 PM
whodeyrob
Chrysler Pacifica
0
11-24-2009 09:35 AM
joeuc23
Chrysler Voyager & Town & Country
4
10-15-2008 05:30 PM
svossen
Chrysler 200 & Sebring
1
04-26-2006 03:30 AM


Thread Tools
Search this Thread
Quick Reply: Multiple issues...so lost


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.