98 Cirrus Tranny problems during winter

  #1  
Old 02-08-2009, 03:04 AM
Senior Member
Thread Starter
Join Date: May 2008
Location: Gatineau, QC, Canada
Posts: 119
Exclamation 98 Cirrus Tranny problems during winter

Hey guys, can anyone help me clear this situation. When its cold out, I have to let my car warm up before i leave (lol). Even after 30 minutes, my tranny does not always grab. For example, if i park nose first, i can go into reverse but when shifting to drive, i'm not moving. If i back in to my parking, i can leave no problem but as soon as i apply the brakes, boom, tranny does not grab again. Its like if my car as to warm up for 45 minutes for the tranny to be ok. If i drive around for lets say 1 hour, park the car for 3 hours, when i get back up and let it warm up for 5 minutes, no tranny problems. only when it sits in the cold for more than 4 hours. my dad does not seem to know whats wrong as he as always had Dodge and hes never had this problem. Oh, when i have to brake (very tight with the line) because the light is changing and i can't make it, it seems like the tranny goes off its gears. HELP ME PLEASE
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
elguappo
Chrysler 200 & Sebring
6
11-03-2013 05:26 PM
jlampitt
Chrysler Voyager & Town & Country
11
02-10-2011 09:56 PM
b_ron007
Chrysler Voyager & Town & Country
2
12-22-2010 04:54 PM
Psungee
General Tech
3
10-18-2007 02:01 PM


Thread Tools
Search this Thread
Quick Reply: 98 Cirrus Tranny problems during winter


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.