Go Back  Chrysler Forum - Chrysler Enthusiast Forums > General Chrysler Forums > Forum Issues
Reload this Page >

08 300c Wrong oil at the Service Dept Fullerton Auto Please Help

Forum Issues Need help with Chrysler Forum? Ask. Have a suggestion to better Chrysler Forum? Tell us here.

08 300c Wrong oil at the Service Dept Fullerton Auto Please Help

  #1  
Old 05-27-2010, 02:40 AM
Junior Member
Thread Starter
Join Date: May 2010
Posts: 1
Default 08 300c Wrong oil at the Service Dept Fullerton Auto Please Help

I've had my 08 300c now for almost two years, I switched over to Synthetic from one of their recomondations. I used it for 3 oil changes. After the 4th change I brought it right back in for preformance issues. Shifting hard and dosent have the same power. And a noise that sounds like muffeld rattles. when you take off or get on it. Ive been back 2 them 3-4 times for this now. Changed the plugs and cleaned the jets said it wasnt running on all 8. First time, 2nd time reset driving memory sensor, third time same thing. Well car wouldnt start 2 days ago with remote. Tried manually a few times wouldnt start. Let it sit a few minutes after another failed attempt it gave a long effort and it started. I brought it right in for this problem and an oil change. I always tell them I use straight Synthetic. When I got the bill I knew they used the wrong oil Back in Jan after I asked and asked and asked for them to double check. Each time being told everything was fine. Well this is when I started to see the diffrence big time. They put a synthetic blend in it. Not full Synthetic. The car needs a crank sensor? I think thats the word for it. Ohh and the lights that came on when it finally started were IMT, ETC, ESP, they said this was what was causing the problems. The part should be in tomorrow. When I complained about the oil they said it wouldnt of hurt the vechicle. Not to worry. This is after I paid 145dollars for them to cut rotors for slight vibration when braking. Only to be left with LOUD Squealing everytime you stop. The want to charge me 115 for pads to fix the squeaking. They created the problem. Can anyone please please help me. Thank you I know its long. But Im really stuck here.
 
  #2  
Old 06-24-2010, 07:12 AM
Junior Member
Join Date: Apr 2010
Posts: 25
Default

Will You have the crank sensor went bad Have you noticed that your car was using more fuel at the highway that is downhell or stright. If yes Inssist that they check the MDS (multy displacment System) which switches your car From V8 to V4 while hiting a brake or driving at stable speed on a stright horizon street or even down for long time

If that System is Efficted and dosent work then For sure the OIL have ruind your car. MDS system is highly Efficted by Oil types and the wrong type and wrong wight of oil Will cause the system to stop working and your engine will remain V8 all the time.
OIL type for V8 is
5-W20
0-W40 (MOBIL1 recomanded)
5-W40 (not recomanded by me I didnt like it)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
degree01
Chrysler 200 & Sebring
2
01-09-2012 08:34 AM
08retract
Chrysler 200 & Sebring
12
05-07-2011 08:05 PM
marcusamaura
Chrysler Voyager & Town & Country
1
08-30-2010 11:37 AM
noocha2b
Chrysler 200 & Sebring
3
10-29-2009 03:27 PM
tshall
Chrysler Voyager & Town & Country
1
07-05-2008 01:32 AM


Thread Tools
Search this Thread
Quick Reply: 08 300c Wrong oil at the Service Dept Fullerton Auto Please Help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.