Forum Issues Need help with Chrysler Forum? Ask. Have a suggestion to better Chrysler Forum? Tell us here.

2016 200s Coolant Issues

  #1  
Old 02-20-2019, 05:15 AM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 4
Angry 2016 200s Coolant Issues

I smell antifreeze outside and inside of my engine compartment but find no leaks. Recently had cylinder heads and associated parts replaced under warranty due to combustion gasses detected in the coolant. I still smell antifreeze. In restaurant drive thru, I could smell antifreeze while sitting in the drivers seat. No leaks found. Engine temp would go to 230-234. Any ideas?
 
  #2  
Old 02-20-2019, 06:51 AM
Senior Member
Join Date: Jul 2017
Location: Western NY
Posts: 811
Default

Originally Posted by chrysler200s View Post
I smell antifreeze outside and inside of my engine compartment but find no leaks. Recently had cylinder heads and associated parts replaced under warranty due to combustion gasses detected in the coolant. I still smell antifreeze. In restaurant drive thru, I could smell antifreeze while sitting in the drivers seat. No leaks found. Engine temp would go to 230-234. Any ideas?
An "old fashioned" coolant system pressure test would find any leak, rather than running it at temp and any leaking coolant burning off. So you say there is NO loss of coolant at all in the radiator/overflow res?
 
  #3  
Old 02-20-2019, 01:40 PM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 4
Default

If coolant is lost it is a slow loss. No visable coolant on the garage floor, or anywhere else. This is the first car I have had with the pressure cap on the coolant reservoir. Can coolant vapor be released from the cap causing the smell? The reservoir is half filled with coolant and air in the rest. Just wondering.
 
  #4  
Old 02-20-2019, 04:44 PM
Senior Member
Join Date: Jul 2017
Location: Western NY
Posts: 811
Default

It is possible that the pressure cap may be bad...cheap enough part to replace and try. BUT having the system put under pressure when not running would show even a small leak. Strange that for such a new car that the work posted of being done was needed.
 
  #5  
Old 02-21-2019, 12:18 PM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 4
Default

Unfortunately the car suffered multiple cylinder #1 misfires even before the coolant issues. Several trips to service for misfires alone. I have a 3.6L and was told there was issues with some of the cylinder heads when they were casted. I changed the coolant reservoir cap last night and drove it this morning. I will update my post with the results.
 
  #6  
Old 02-23-2019, 02:41 PM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 4
Default

Today, I was sitting on the passenger side when I got out of the car after it being driven about 10 miles. Upon exiting the door, I smelt a big whiff of the coolant. My wife who was driving popped the latch for the hood. I opened the hood but did not see anything abnormal. I also saw that the hose at the top of the reservoir was returning coolant to it. Does this seem normal? Even with the new radiator pressure cap, the same event of smelling antifreeze occurs. Is it normal to smell antifreeze in a 200s with a 3.6L?

While the car was idling
in my driveway I did verify that the fans for the radiator came on at 233 deg. This was using the digital display in my car.

I would appreciate any insite to this.

 
  #7  
Old 02-24-2019, 07:02 AM
Senior Member
Join Date: Jul 2017
Location: Western NY
Posts: 811
Default

Originally Posted by chrysler200s View Post
Today, I was sitting on the passenger side when I got out of the car after it being driven about 10 miles. Upon exiting the door, I smelt a big whiff of the coolant. My wife who was driving popped the latch for the hood. I opened the hood but did not see anything abnormal. I also saw that the hose at the top of the reservoir was returning coolant to it. Does this seem normal? Even with the new radiator pressure cap, the same event of smelling antifreeze occurs. Is it normal to smell antifreeze in a 200s with a 3.6L?

While the car was idling
in my driveway I did verify that the fans for the radiator came on at 233 deg. This was using the digital display in my car.

I would appreciate any insite to this.
NO it's not normal and you should take it back in and have them do a coolant system pressure test to find the slight leak that's giving you that smell!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rawko
Chrysler 200 & Sebring
0
09-06-2015 03:25 PM
traildog
General Tech
0
11-28-2014 02:47 PM
Chrysler Forum Editor
Brand News, Concepts & Rumors
0
06-25-2014 08:38 AM
Chrysler Forum Editor
Brand News, Concepts & Rumors
0
06-02-2014 11:08 AM
2010vert
Chrysler 200 & Sebring
0
12-19-2013 01:05 PM


Thread Tools
Search this Thread
Quick Reply: 2016 200s Coolant Issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.