Forum Issues Need help with Chrysler Forum? Ask. Have a suggestion to better Chrysler Forum? Tell us here.

A/C problem on a 2004 Town and Country

  #1  
Old 08-06-2010, 03:30 PM
Junior Member
Thread Starter
Join Date: Jul 2010
Posts: 3
Default A/C problem on a 2004 Town and Country

I have 2004 Town and Country, the resistor for the front blower went out and the fan stopped working. I replaced the resistor and it started back up, but I smell something burning whenever I turn it from high to a lower speed. Any suggestions on what this could be? Thank you for the help.
 
  #2  
Old 08-06-2010, 09:36 PM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,105
Default

possible just the new resistor has stuff on it or the blower motor is shorting that one out to
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
stmiller96
Chrysler Voyager & Town & Country
0
05-20-2012 07:50 PM
stmiller96
Chrysler Voyager & Town & Country
6
05-04-2012 03:41 PM
stmiller96
Chrysler Voyager & Town & Country
10
04-22-2012 01:30 PM
slstaton
Chrysler Voyager & Town & Country
2
09-27-2010 10:00 PM
FCPorto
Chrysler Voyager & Town & Country
5
05-28-2007 11:29 AM


Thread Tools
Search this Thread
Quick Reply: A/C problem on a 2004 Town and Country


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.