06 300c v6 wagon - Chrysler Forum - Chrysler Enthusiast Forums

General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

06 300c v6 wagon

Reply

 
 
 
  #1  
Old 04-13-2018, 06:43 AM
Junior Member
Thread Starter
Join Date: Apr 2018
Posts: 1
Default 06 300c v6 wagon

Having trouble with dash/cluster lights staying on when I remove the key..
Also when I first turn key and hold it ,the gauges all work, ie fuel speed and temp, when I let key go in normal position (car idling) none of them work/move ..have tried a few things * checked for wire corrosion under carpet behind driver seat
*auto elect has gone over it,every symptom was pointing to the switch past/behind ignition ,but that switch is fine
*pressed hazards twice(as google said) and it did nothing
*all fuses are good
* everything works ,just cluster lights not turning off when keys removed
*and cluster guages only move/work when I turn key slightly and hold it,when I release key and car starts the gauge needles go back to not working
Please any suggestions are appreciated..
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
snoopycruiser
Off Topic
3
04-27-2007 03:35 AM
xyzeno
Chrysler Voyager & Town & Country
2
02-22-2007 10:42 PM
Midnight 85
Brand News, Concepts & Rumors
0
10-19-2006 01:21 PM
ViperGTS
Brand News, Concepts & Rumors
3
09-18-2005 11:08 PM
ViperGTS
Brand News, Concepts & Rumors
1
12-28-2004 02:29 AM


Thread Tools
Search this Thread
Quick Reply: 06 300c v6 wagon


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.