General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

low beam lights don't work

  #1  
Old 12-18-2007, 02:49 PM
Thread Starter
Join Date: Dec 2007
Posts: 9
Default low beam lights don't work

hello, i was wondering if anyone can help. i have an 06 Pacifica that has no current going to my low beams. my high beams work and every other lights except my lows.
my low beam lights do work cause i switched them with the high ones and they turn on. when i put them back in the lows and turn on the low lights they don't turn on. I think itsa fuse i checked the fuse box next to the battery but don't see any fuses for both low beams.
What can i do, what is the problem
Please help me with this problem i can't drive my car at night
 
  #2  
Old 03-15-2008, 10:14 PM
Member
Join Date: Jul 2007
Posts: 41
Default RE: low beam lights don't work

moe in wichita ks
my guess is its eather the headlight switch or the wire connector is not pluged in enough.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
wig6516
General Tech
16
02-06-2016 08:10 PM
vgarfield
Chrysler 200 & Sebring
1
12-18-2013 11:19 AM
lmekic06
Chrysler 200 & Sebring
0
11-13-2011 03:52 PM
ajs42548
Chrysler Voyager & Town & Country
6
01-19-2011 01:45 PM
wig6516
Forum Issues
0
12-18-2007 02:38 PM


Thread Tools
Search this Thread
Quick Reply: low beam lights don't work


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.