Other Any other Chrysler within.

95 LeBaron - wont start after heavy rains

  #1  
Old 08-15-2011, 10:45 PM
Junior Member
Thread Starter
Join Date: Aug 2011
Posts: 2
Default 95 LeBaron - wont start after heavy rains

95 LeBaron w/ 93000 miles. When there is a heavy rainfall my engine will not turnover. I have full electrical, starter works fine, belts and pulleys are moving, spark plugs are good.

When I do get the engine started, she runs beautifully. If I let the car "dry out" for 2 days, it starts just fine.

Looking to get the vehicle running 7 days a week, do not want to replace my awesome car.
 
  #2  
Old 08-16-2011, 08:11 PM
Member
Join Date: Oct 2010
Location: New Brunswick,Canada
Posts: 41
Default

you need to replace your spark plug wires and or distibutor cap.
 

Last edited by DrGadget; 08-16-2011 at 08:18 PM.
  #3  
Old 08-16-2011, 11:07 PM
Junior Member
Thread Starter
Join Date: Aug 2011
Posts: 2
Default

when i bought the car 2 years ago, i had new wires put in.. will look further into this.

thanks for the suggestion.
 
  #4  
Old 04-03-2013, 10:04 AM
Junior Member
Join Date: Apr 2013
Posts: 4
Default

If moisture gets in to your disrtibutor cap it wont or will be hard to start
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
monchito_yeyeye
Chrysler 200 & Sebring
1
04-25-2014 09:16 AM
Budman
Cirrus & Breeze
3
06-02-2013 07:21 PM
Simpol
Chrysler 200 & Sebring
3
10-02-2010 07:00 PM
kushn
Chrysler 200 & Sebring
1
08-12-2010 10:54 AM
rmichels
Chrysler Voyager & Town & Country
2
06-25-2007 07:46 AM


Thread Tools
Search this Thread
Quick Reply: 95 LeBaron - wont start after heavy rains


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.