Chrysler 200 & Sebring Whether it be the sedan, coupe, or convertible, this mid-sized model offers a touch of class to every style in it's lineup

'96 JXI starting problem

  #1  
Old 05-21-2010, 08:37 AM
Junior Member
Thread Starter
Join Date: May 2010
Posts: 9
Default '96 JXI starting problem

So my new to me JXI doesn't want to start.

When I got the car it had a completely flat battery in it. Replaced with new. Second or third start I thought it was spinning a little slow but every time after that has been fine.

Yesterday I replace the broken rear window regulator. After replacing it I get in and turn the key and get "Click" and that's it. I thought I had run the battery down having the interior lights on so I put the charger on it overnight.

Today I get the "click" but if I just hold the key it starts to grunt a little then rrrr rrrr rrr like a dead battery and once it gets a little spin going it ramps up to full crank speed. AutoZone just checked the battery and says it is good and charging system is good. Battery cables are cool to the touch so I don't think I have a bad connection. Before I blow $120 on a starter is there something else I should be looking for?

Steve B.
 
  #2  
Old 05-21-2010, 02:50 PM
dcotter0579's Avatar
Senior Member
Join Date: May 2008
Location: Detroit suburb
Posts: 4,993
Default

Look for corrosion in all the connections between the starter and the battery.
 
  #3  
Old 06-04-2010, 11:12 AM
Junior Member
Join Date: May 2010
Posts: 6
Default distributor

It's the distributor. the 1996 model has a problem with them. I am replaceing mine as we speak.
 
  #4  
Old 06-05-2010, 07:33 AM
Junior Member
Thread Starter
Join Date: May 2010
Posts: 9
Default

It was the starter. Replaced it and it starts right up.

Steve
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
byteasc
Chrysler 200 & Sebring
5
12-22-2013 09:28 AM
bamabeauty81
Chrysler 200 & Sebring
0
01-06-2012 05:13 PM
Beware_of_Dog
Chrysler 200 & Sebring
0
05-26-2010 06:18 AM
evanjah
Chrysler 200 & Sebring
4
12-20-2008 08:08 AM
97jxi
General Tech
1
08-25-2007 09:30 PM


Thread Tools
Search this Thread
Quick Reply: '96 JXI starting problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.