Chrysler 200 & Sebring Whether it be the sedan, coupe, or convertible, this mid-sized model offers a touch of class to every style in it's lineup

Oil pressure light 2.7 2001 sebring

  #1  
Old 02-07-2009, 11:07 PM
Junior Member
Thread Starter
Join Date: Jan 2009
Posts: 5
Default Oil pressure light 2.7 2001 sebring

Hello
I recently bought a non running 2.7 the waterpump was bad so I replaced the water pump and the timing chain tensioner!! Now I can drive the car When it got good and warm on the highway the oil light came on and stayed on when I stopped it died and was hard to start ??? The engine isnt making and noises it is good and quiet?? Did they have oil pump issues with this motor???? I think I will pull the pan and investigate please respond with any help .
Matt
 
  #2  
Old 02-17-2009, 07:51 PM
Junior Member
Join Date: Feb 2009
Posts: 2
Default

e same problem with 01 2.7 and i ended up have to replace the motor... that particular motor wasent the best chrysler ever produced, something to the effect of oil slugde preventing the proper oil pressure... may want to have it looked at...
 
  #3  
Old 02-18-2009, 02:07 PM
Senior Member
Join Date: Apr 2008
Location: Northern California
Posts: 278
Default

Some have recommended Seafoam additive for this issue.

Pull your pressure sensor and check for sludge in the sensor and port.

Also, if you have a vacuum leak or leaky EGR system, those will cause hard hot starts.
 
  #4  
Old 02-20-2009, 12:11 AM
Junior Member
Thread Starter
Join Date: Jan 2009
Posts: 5
Default Now oil light flickers when I come off the highway??

Hello
I pulled the valve covers and found no oil to cam journals had melted the journals to the camshaft so I pulled the engine put new mains and rod bearings in it also replaced the oil pump and pick up and the front cylinder head I also put a new oil sending unit in while it was on the stand if I drive it 2o mile of interstate when I get off and come to a stop the oil light just flickers and if I turn the steering while it will pull the engine down and the light comes on if I bump it into neutral it stays off??? Hopefully someone will give me a hint of what to do next!!!
Matt
 
  #5  
Old 02-21-2009, 09:01 PM
dcotter0579's Avatar
Senior Member
Join Date: May 2008
Location: Detroit suburb
Posts: 4,993
Default

The idle air control motor is supposed to activate to keep the engine idling at sufficient RPM under loads such as from the a/c or power steering. You might want to make sure that's working properly.
 
  #6  
Old 03-10-2010, 08:14 AM
Junior Member
Join Date: Mar 2010
Location: KC
Posts: 13
Default Issue Resolved?

Has this issue been resolved yet?
 
  #7  
Old 03-13-2010, 02:13 AM
Member
Join Date: Aug 2009
Location: Palm Springs CA
Posts: 63
Default

Originally Posted by mjakobh View Post
Hello
I pulled the valve covers and found no oil to cam journals had melted the journals to the camshaft so I pulled the engine put new mains and rod bearings in it also replaced the oil pump and pick up and the front cylinder head I also put a new oil sending unit in while it was on the stand if I drive it 2o mile of interstate when I get off and come to a stop the oil light just flickers and if I turn the steering while it will pull the engine down and the light comes on if I bump it into neutral it stays off??? Hopefully someone will give me a hint of what to do next!!!
Matt
Originally Posted by dcotter0579 View Post
The idle air control motor is supposed to activate to keep the engine idling at sufficient RPM under loads such as from the a/c or power steering. You might want to make sure that's working properly.

^^^ This...

What RPM is it idling at when in gear at a stop? It may simply be idling too slowly to keep the light off...
Of course, if it were disconnected, it SHOULD throw a code....

Just a thought.
 
  #8  
Old 07-26-2010, 07:54 PM
Junior Member
Join Date: May 2010
Posts: 9
Default

Hope it`s just oil pressure sensor, check this thread:
https://www.chryslerforum.com/forum/...ead.php?t=3386
 
  #9  
Old 02-15-2011, 09:00 PM
Junior Member
Join Date: Feb 2011
Posts: 4
Smile Does anyone have an answer on this?

Hi I have the same problem as mentioned above. I just rebuilt my 2.7L engine with new rod, crankshaft, bearings. There is no evidence of sludge in the motor at all. So we have it all put together it runs awesome until the car reaches normal operating temp. I will have it in park just idling in the garage and every 30 seconds or so idle will drop and act like it will die and the oil light flickers and stays on. I checked the oil and it is fine. I am just doing some searches around on the internet to find out where to start and how to fix. Only thing going for me is I know its not a sludge issue. Just for FYI original problem why engine broke down was it had a small oil leak and mother in law drove it bone dry and broke the bearings, rod, and wore down the crankshaft. I look forward to replies either on here or my email at [email protected]. Thanks.
 
  #10  
Old 02-16-2011, 09:55 AM
Junior Member
Join Date: May 2010
Posts: 9
Default

Originally Posted by Mcdonaho View Post
Hi I have the same problem as mentioned above. I just rebuilt my 2.7L engine with new rod, crankshaft, bearings. There is no evidence of sludge in the motor at all. So we have it all put together it runs awesome until the car reaches normal operating temp. I will have it in park just idling in the garage and every 30 seconds or so idle will drop and act like it will die and the oil light flickers and stays on. I checked the oil and it is fine. I am just doing some searches around on the internet to find out where to start and how to fix. Only thing going for me is I know its not a sludge issue. Just for FYI original problem why engine broke down was it had a small oil leak and mother in law drove it bone dry and broke the bearings, rod, and wore down the crankshaft. I look forward to replies either on here or my email at [email protected]. Thanks.
Hello! My problem has been solved replacing oil pressure sensor, it was leaking inside and had had the same symptoms as yours. I`ve already gone 10k miles after replacement without any problems. Please see this thread
https://www.chryslerforum.com/forum/...ead.php?t=3386
 

Thread Tools
Search this Thread
Quick Reply: Oil pressure light 2.7 2001 sebring


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.