Chrysler 300, 300C & 300C SRT-8 The flagship of the Chrysler lineup offers the driver every bit of class of any European luxury sedan, combined with the availability of the Hemi, the engine which dominated the American Muscle Car Era

2002 300M technical assistance needed with working on the P340 code...

  #1  
Old 03-27-2014, 09:26 PM
Junior Member
Thread Starter
Join Date: Mar 2014
Posts: 5
Question 2002 300M technical assistance needed with working on the P340 code...

I have been on another site trying to find someone who has dealt with the same issue that we are in our shop with nothing to show but a REALLY bad migraine...I am praying by some of the posts that I've seen here that someone will be able to help me
We have a 2002 300M in the shop with the 3.5L high output engine..it was first brought in as a repo we did and now it's got to be fixed for us to sell...long story short here goes what I know...
heads were done and replaced on the car...new plugs,wires and such...when we got the engine all back together the P340 code showed up. The sensor has been replaced(2 different ones in case the first one was faulty) along with the crank sensor as well. The car will crank and idle nicely,but when you rev the engine up to about 2400RPM it cuts out like you have "red lined" it. Already took the timing cover back off and it is fine and also hasn't jumped time...checked the exhaust system too... Having checked all the "obvious things" that could be causing the code to continue,along with the cutting out problem, my mechanic is stumped. Can you tell me if this is a common issue with this vehicle and engine or have a lot of others had the same thing happen? I'm hoping that this is an oddball situation with an easy fix and that someone can please give me some insight on it. Thanks so much and I look forward to some suggestions.
 
  #2  
Old 03-28-2014, 07:37 AM
Senior Member
Join Date: Sep 2012
Location: Somerset N.J.
Posts: 393
Default

There was one instance where the tone ring on the left (drivers) side came loose or was damaged that I recall causing a similar issue. (note part of the cam drive & special tool needed)
Are you using an OEM sensor? Aftermarket ones have been a problem. Are you leaving the paper shim/spacer on? Must leave it on as it sets the gap for the sensor. Wires all OK?
Are you hitting the neutral rev limiter? (usually around 3500)
Does it drive OK?
 
  #3  
Old 03-28-2014, 10:09 AM
Junior Member
Thread Starter
Join Date: Mar 2014
Posts: 5
Default Re: Firem

Thanks for your response this morning! I called my local dealership and priced the camshaft sensor as my mechanic had gotten the 2 he replaced the faulty one with from Advance...I'd told him last nite that everything I had read online kept reinforcing the issue of the aftermarket ones not working properly. So he is in process of ordering one from Chrysler as I'm posting...I asked the parts guy at the dealership if he was familiar with the tone ring you mentioned and he looked and says that the 2002 does not list one on the car. We have not been able to test drive the car yet as worried since in idle we cannot get it up to quite 2400RPM before it's cutting out like you have "red lined" it. All of the "obvious" type other causes have been checked...like timing belt is good and hasn't jumped time,wiring,exhaust system and we also replaced the crankshaft sensor as well... can you elaborate on the tone ring portion a little bit more in case the dealership is calling it something different? Thank you so very much!
 
  #4  
Old 03-28-2014, 11:51 AM
Junior Member
Thread Starter
Join Date: Mar 2014
Posts: 5
Default NEW Codes as well......

Also the P0700 and P0888 codes have appeared...From what I have read allready this means the PCM needs to be reflashed at the dealership. Would the speed input and output sensors need to be replaced first before taking it to have it reflashed?...or should I have the PCM reprogrammed before replacing the speed sensors?... Oh I love this car lol. I just want to make sure that someone buying the vehicle has a sound car when they purchase it from us and that they won't drive it for a week and then have to bring it back for any issues. A good name and good service makes for a great business
 
  #5  
Old 03-28-2014, 02:52 PM
Senior Member
Join Date: Jul 2011
Location: Auburn Hills, MI
Posts: 566
Default

Have you reviewed TSB 18-015-09?

SUBJECT:
Flash: MIL Illumination Due To Diagnostic Trouble Code P0340 Or P0344

OVERVIEW:
This bulletin involves selectively erasing and reprogramming the Powertrain Control
Module (PCM) with new software.

NOTE: This bulletin applies to:
DR vehicles equipped with a 3.7L/4.7L/5.7L engine (sales code EKG, EVA, EVD,
EZA or EZB)
2002 LH vehicles equipped with a 2.7L or 3.5L engine (sales code EER, EES, EGC,
EGG, EGK or EGJ)
2003 and 2004 LH vehicles equipped with a 2.7L engine (sales code EER)
LX/LE vehicles equipped with a 2.7L/3.5L or 5.7L engine (sales code EER, EGG or
EZB)
JR vehicles equipped with a 2.7L engine (sales code EEE or EER)
TJ vehicles equipped with a 4.0L engine (sales code ERH)
AN vehicles equipped with a 3.7L or 4.7L engine (sales code EKG or EVA)
ND vehicles equipped with a 3.7L or 4.7L engine (sales code EKG, EVA or EVC)
PT vehicles equipped with a 2.4L engine (sales code EDZ)
DN vehicles equipped with a 4.7L engine (sales code EVA)

SYMPTOM/CONDITION:
The software contains the following improvements for all customers:
A MIL illumination for P0340 - Camshaft Position Sensor Circuit - Bank 1 Sensor 1
A MIL illumination for P0344 - Camshaft Position Sensor Intermittent - Bank 1
Sensor 1
 
  #6  
Old 03-28-2014, 02:55 PM
Senior Member
Join Date: Jul 2011
Location: Auburn Hills, MI
Posts: 566
Default

NUMBER: 18-014-02

SUBJECT:
Transaxle Limp-In, Engine Misfire, Engine No-Start

OVERVIEW:
This bulletin involves diagnosing a transaxle solenoid and/or ignition coil issue, and
replacing the Powertrain Control Module (PCM) if necessary.

MODELS:
2002 (LH) Concorde/Intrepid/300M
NOTE: THIS BULLETIN APPLIES TO VEHICLES BUILT BEFORE JANUARY 28, 2002 (MDH 0128XX).

SYMPTOM/CONDITION:
Vehicle may exhibit one or all of the following symptoms:
• The transaxle is in limp-in mode with Diagnostic Trouble Codes (DTC) P0750, P0755,
P0760, P0765, Solenoid Continuity Errors.
• The vehicle is a no-start (cranks but will not start), or engine misfire, and /or DTC
P0351, P0352, P0353, P0354, P0355, P0356, Ignition Coil Primary Circuit Fault.
DIAGNOSIS:
If Diagnostic Trouble Codes (DTC’s) are present other than those listed above, record them
on the repair order and repair as necessary before proceeding further with this bulletin. If the
condition(s)/DTC’s listed are present or can be duplicated, perform the Repair Procedure.
REPAIR PROCEDURE:
NOTE: WHENEVER A PCM IS REPLACED OR REPROGRAMMED, THE
SOFTWARE MUST BE VERIFIED AS HAVING THE LATEST REVISION
LEVEL AND THE PINION FACTOR MUST BE SET.
NOTE: THIS REPAIR PROCEDURE IS DIVIDED INTO TWO PROCEDURES
DEPENDING ON THE VEHICLE SYMPTOMS.
Transaxle Limp-In/DTC P0750, P0755, P0760, P0765
1. Record "EVENT DATA" for the corresponding DTC stored in memory.
Note the specific operating conditions for :
• Trans sump temp
• Engine rpm
• Input (turbine) rpm
• Output rpm
• Throttle angle
• PRNDL position
• Ingear code
• Last shift or shift in progress
• Coolant temperature
 
  #7  
Old 03-28-2014, 04:52 PM
Senior Member
Join Date: Sep 2012
Location: Somerset N.J.
Posts: 393
Default

P0888 is a new one on me, may well need a reflash. I would carefully check ALL power and grounds starting at tha battery and jump posts first.

As far as the tone ring is concerned it is part of 04792580AA SPROCKET, Camshaft
I can't find it now but it was on one of these sites
http://300mclub.org/
http://www.lhforums.net/forums/forum.php
http://www.dodgeintrepid.net/
All of them are searchable for some information for free
 
  #8  
Old 03-29-2014, 07:30 PM
Junior Member
Thread Starter
Join Date: Mar 2014
Posts: 5
Thumbs up Thank you SO very much!

Thanks so much to both of you...the sensor from the dealership fixed that issue. Also replacing 2 fuses (one for the gic lighter and then another one that was a 15AMP unmarked but right beside the PCM's) As far as the tranny issues I will be checking into that on Monday. I was very glad to find your site and learn a lot from it just by reading a lot of the other threads from members. I will post back and let you know what happens after the first of the week and exactly what fixed the issue on the P0888 code...what I do know about it is this "DTCP0888 for All Makes Category: Powertrain Definition: TCM Power Relay Sense Circuit Definetivelly you'll need visit your dealer... this code refers to the Transmission Control relay output circuit in the PCM (Power Control Module), when the relay is commanded to turn on the PCM is not seeing the relay power on, most of the time when we see this code, it can be cured by doing a re-flash on the Power Control Module"

Again thanks for your help and knowledge. God bless and good weekend to all!
 
  #9  
Old 04-03-2014, 06:51 PM
Junior Member
Thread Starter
Join Date: Mar 2014
Posts: 5
Default

Just to let yall know after replacing the input and output sensors on the tranny the tran codes went away and the car is running and shifting fine..told my mechanic if any more probs appear we will have the PCM reflashed...and instead of selling it to someone else a co-owner in the business decided that he wanted it and we have let him have the car...so if the PCM does need programming in the future we will cover it at no cost to him. Again I want to say a special thank you for all your input and help on this car. I will be recommending your site to anyone that I know who is working on any make of Chrysler vehicle and surely coming back to you if we have any more come into the shop that you may could help us on. I am SO glad to have found yall!
 
  #10  
Old 04-03-2014, 08:41 PM
Senior Member
Join Date: Sep 2012
Location: Somerset N.J.
Posts: 393
Default

Hope he enjoys the 300M, tell him about the forums, have him stop in.
Drive = Love
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
recepomac
General Tech
0
04-14-2015 07:53 AM
KyleCAC
General Tech
1
08-10-2014 07:18 PM
My08tc
Chrysler Voyager & Town & Country
2
05-12-2009 10:02 PM
Mikestravels
General Tech
1
02-19-2009 04:40 PM
Sparkplugs.com
General Tech
0
12-01-2006 02:56 PM


Thread Tools
Search this Thread
Quick Reply: 2002 300M technical assistance needed with working on the P340 code...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.