Chrysler Aspen This new SUV adds a luxury touch to the performance and quality that you would expect from a Chrysler Corp. SUV.

2008 Chrysler Aspen Nav error

  #1  
Old 01-28-2015, 07:36 PM
Junior Member
Thread Starter
Join Date: Jan 2015
Posts: 2
Default 2008 Chrysler Aspen Nav error

Hi all. I recently purchased a 2008 Chrysler Aspen Limited Edition. Gotta say right away... Love it!!! I got it with only 28,000km. It is showroom condition. I now have 56,000km on it.


A recent problem occurred. The navigation stopped working. It was working fine 3 days ago. But one time while out of town, I started my truck, pressed the NAV button and it said Navigation is being activated... and never connected. I thought I could just restart my truck, but no luck. My Phone will still connect but the voice promts are gone. Everything I had on the HD are also gone. In the System Information screen, it shows SOFTWARE Database ERROR! TAG NOT FOUND.


Its been like this for 3 days.
I've checked all fuses and they all seem fine.
I thought about disconnecting the battery for a few hours to see if that would do anything.


Anyone have experience with this? Any suggestions on what I should do?


I'd attach pictures if I know how.
 
  #2  
Old 01-29-2015, 08:18 AM
Senior Member
Join Date: Mar 2014
Location: Windsor
Posts: 108
Default

Originally Posted by Stablockaspen View Post
Hi all. I recently purchased a 2008 Chrysler Aspen Limited Edition. Gotta say right away... Love it!!! I got it with only 28,000km. It is showroom condition. I now have 56,000km on it.


A recent problem occurred. The navigation stopped working. It was working fine 3 days ago. But one time while out of town, I started my truck, pressed the NAV button and it said Navigation is being activated... and never connected. I thought I could just restart my truck, but no luck. My Phone will still connect but the voice promts are gone. Everything I had on the HD are also gone. In the System Information screen, it shows SOFTWARE Database ERROR! TAG NOT FOUND.


Its been like this for 3 days.
I've checked all fuses and they all seem fine.
I thought about disconnecting the battery for a few hours to see if that would do anything.


Anyone have experience with this? Any suggestions on what I should do?


I'd attach pictures if I know how.
Stablockaspen,

Congrats on your Aspen and welcome to the forum.
A handful of radio flash updates have been released over the years, worth checking it out with your local Chrysler dealer.
All the best!
 
  #3  
Old 01-30-2015, 07:47 AM
Senior Member
Join Date: Dec 2008
Posts: 513
Default

Yeah, you need a software update. I've done it at least 5 times on mine (to get the latest versions). Google "update mygig software" or something similar and you'll find more information on this than you can handle.

BTW, there's zero reason to pay a dealer to do this unless you're just uncomfortable with creating the disc and sitting in your Aspen for 20 minutes while it updates.
 
  #4  
Old 01-30-2015, 10:19 AM
Junior Member
Thread Starter
Join Date: Jan 2015
Posts: 2
Default

Thank you 15951a\


I Googled "update mygig software" and found a bunch of information including videos of people inserting a disc and updating. I'm happy to see that its just that easy. However, after 15 min or so of surfing and sifting, I'm still can not find where or how to made the updating disk. Do you, or anyone, have a more descriptive instruction on where and how I can obtain this?


Greatly appreciated.
 
  #5  
Old 01-30-2015, 11:30 AM
Senior Member
Join Date: Dec 2008
Posts: 513
Default

I've revised my original reply, because it looks like your hard drive is failing based on the following summary of error messages.
Error messages:
"Navigation is being activated" message may appear momentarily when the radio is first turned on and in the navigation mode. This is normal while GPS satellites are being located. If message does not go away after driving on main roads for a few minutes, push the Menu button on the radio and select "System Set Up", and then "System Info". Check for "Tag Not Found" or "Not applicable" messages described below.

"Tag Not Found" - Displayed on navigation information page. Critical error, radio must be replaced due to internal HDD failure.

"Not applicaple/NA msg" - Displayed in Gracenote area. Critical error, radio must be replaced (non-navigation REN models).

"EMERGENCY UPDATE/ERROR(256): failed to flash update ifs" - Error when updating software. Disconnect battery negative terminal (or radio power) for one hour or longer. Restore power, disc should read properly and complete update.

Here's a link to a site selling hard drive's with software preloaded. I would expect this to cost quite a bit less than replacing the entire unit. -- MyGig Problem? | Fix it Yourself | Now
 

Last edited by 15951a\; 01-30-2015 at 01:37 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
losgranos
Chrysler Pacifica
0
12-23-2014 09:32 AM
christyf
Chrysler Aspen
1
08-16-2013 01:18 PM
HemiAspen4me
Chrysler Aspen
4
01-02-2013 12:20 PM
rjsmom
Chrysler Voyager & Town & Country
2
11-29-2007 03:20 PM
Aleasha
Chrysler Pacifica
0
03-26-2007 03:04 PM


Thread Tools
Search this Thread
Quick Reply: 2008 Chrysler Aspen Nav error


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.