Chrysler Aspen This new SUV adds a luxury touch to the performance and quality that you would expect from a Chrysler Corp. SUV.

Beyond confused ...need help

  #1  
Old 06-02-2017, 08:31 PM
Junior Member
Thread Starter
Join Date: Jun 2017
Posts: 2
Default Beyond confused ...need help

I have a 2007 chrysler aspen with the 5.7l. After getting it we replaced the plugs all 16 with e3s, all new coil plug boots and 1 coil pack because it was throwing up a code for misfire. Ran fine for a couple mths then oil light came on got code for oil pressure sensor . Changed that along with having flow master super 44 put on it. Drove a week and was raining pulled into parking lot and car just died and wouldn't restart. Got crankshaft position sensor code along with check engine light and lightning bolt and anti skid lights on. Towed it home changed cps and it will start rpms jump up and down then stalls. Won't run for more than 20 seconds. No gas pedal at all to try and keep it running. Have changed egr valve, camshaft position sensor, ignition switch, cleaned throttle body but no change. Code p3449 and p0522 check engine light and lightning bolt still on. Anybody have any ideas?
 
  #2  
Old 06-03-2017, 08:40 AM
Senior Member
Join Date: Sep 2014
Location: Dallas, TX
Posts: 261
Default

P3449 is the MDS solenoid for cylinder 7. These solenoids going bad seem to be a common issue. I myself get random P3441 which is cylinder 6. Although it doesn't kill the engine. Just disables fuel saver mode.

The P0522 however, is low oil pressure or oil pressure sensor circuit too low. Now you already changed the sensor so it could possible be a bad oil pump. Then again, you mentioned this last mishap happened while it was raining. I've seen several reports from others who say things go crazy when it rains which means water is getting somewhere it's not suppose to. In this case, possible the PCM. From what I've read, it's suppose to be in the engine compartment mounted to the drivers fender. Based on the fact that you have so many different errors going on, I would start looking there.
 
  #3  
Old 04-30-2018, 11:03 AM
Junior Member
Thread Starter
Join Date: Jun 2017
Posts: 2
Default problem fixed

finally figured out the issue after many trial and errors. the shop who replaced my oil pressure sensor used a non mopar part so after a couple weeks it caused all kinds of electrical issues with the throttle body so it stayed in limp mode. replaced it with mopar and it's running perfect. lesson learned mopar only when replacing this part.
 
  #4  
Old 06-01-2018, 05:28 AM
Junior Member
Join Date: Jun 2018
Location: New York
Posts: 1
Default Wa

Originally Posted by Unforgvn1200 View Post
I have a 2007 chrysler aspen with the 5.7l. After getting it we replaced the plugs all 16 with e3s, all new coil plug boots and 1 coil pack because it was throwing up a code for misfire. Ran fine for a couple mths then oil light came on got code for oil pressure sensor . Changed that along with having flow master super 44 put on it. Drove a week and was raining pulled into parking lot and car just died and wouldn't restart. Got crankshaft position sensor code along with check engine light and lightning bolt and anti skid lights on. Towed it home changed cps and it will start rpms jump up and down then stalls. Won't run for more than 20 seconds. No gas pedal at all to try and keep it running. Have changed egr valve, camshaft position sensor, ignition switch, cleaned throttle body but no change. Code p3449 and p0522 check engine light and lightning bolt still on. Anybody have any ideas?
Water may be getting through the upper front cowl screen (well known problem with dodge/chrysler) and dripping directly on the TPS sensor and may run over and spill over the PCM and other electronic components close to fire wall.. if replacing tps senser do DEALERSHIP ONLY trust me’ . Auto Stores gives out universal tps..the dealership tps are not and much bigger in size.. only use dealership electrical parts for chrysler..
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bwinterstine
Chrysler 200 & Sebring
3
10-07-2011 10:42 AM
data6326
Chrysler Voyager & Town & Country
1
06-17-2011 09:32 AM
dj750
Chrysler 200 & Sebring
1
06-05-2011 09:03 AM
Marlowe
General Tech
3
05-07-2009 06:17 AM
VaSteve
General Tech
2
10-04-2008 02:14 PM


Thread Tools
Search this Thread
Quick Reply: Beyond confused ...need help


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.