Chrysler Pacifica Luxury meets versatility in this mid-sized sport utility vehicle

62TE transmission electronics

  #1  
Old 10-11-2018, 12:00 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 3
Default 62TE transmission electronics

I have a 4.0 with 62TE trans. The top radiator hose leaked onto and shorted the PCM. The local trans shop had it for 6months and gave up. They say that they tried different PCMs, but have no records of that. The wiring harness at the solinoid pack on the trans looks like a 3rd grader has been splicing.
It had been in and out of that shop 3 timess. It was going into limp mode. Now it only has reverse and first. The Autostick also does not work nor does it change from the PRNDL on the dash to the selected gear NUMBER
I get a .P075A code SHIFT SOLINOID G MALFUNCTION.

Any guesses?

My next step is to check the OHMS on the solinoids in the pack.
 
  #2  
Old 10-11-2018, 10:16 PM
Junior Member
Join Date: Feb 2018
Posts: 14
Default

Did the shorted PCM cause any other problems,was the trans working good before?
 
  #3  
Old 10-12-2018, 05:30 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 3
Default

The drivetrain was perfect before the leak. I'm suspecting that I was misled by the mechanic.
I haven't had the car up in the air yet to get a really good look at it, but the PCM doesn't look like it has been changed.
The connector to the solinoid pack has been cut from another harness and spliced into mine..
I am going to unwrap that mess and recheck/verify all of the many individual wire splices.
 
  #4  
Old 10-12-2018, 09:55 PM
Junior Member
Join Date: Feb 2018
Posts: 14
Default

Hopefully it is just the wiring,do you have a schematic?
At least all of the wires go to the PCM and not spread out inside/under the dash.
 
  #5  
Old 10-22-2018, 03:11 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 3
Default Bad Solenoid pack

Awesome video on you tube shows pin ID on solenoid pack.


A check of mine reveals 2 of 7 solenoids are bad. current resistance should be 1.5 ohms
MAIN LINE PRESSURE SOLENOID showed 5.1
DIRECT CLUTCH showed 3.5.
New part on order.
 
  #6  
Old 10-24-2018, 11:01 AM
Junior Member
Join Date: Feb 2018
Posts: 14
Default

Sound like that should take care of it,I changed the one in mine and it was a little tight to get to.I would suggest removing the upper radiator mount/bar and the radiator fans to give you more room,it does not take long to remove those. Keep us posted with the repairs.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
CirellaFamily
Chrysler Voyager & Town & Country
20
04-16-2019 03:41 PM
Lito Mouskounti
300M, Concorde, LHS, New Yorker
0
12-22-2016 12:43 PM
farmerbob02
Chrysler PT Cruiser
1
04-13-2011 12:04 AM


Thread Tools
Search this Thread
Quick Reply: 62TE transmission electronics


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.