Pacifica taking delayed start/check eng light blinking/strong smell/jerky accelerate - Chrysler Forum - Chrysler Enthusiast Forums


Chrysler Pacifica Luxury meets versatility in this mid-sized sport utility vehicle

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 10-11-2017, 06:15 PM
Junior Member
Thread Starter
 
Join Date: Dec 2016
Posts: 12
Default Pacifica taking delayed start/check eng light blinking/strong smell/jerky accelerate

Hello. My 2005 Pacifica is giving me problems again. It was starting fine and running good and suddenly one day it took about 6 seconds of cranking to start, the check engine light is now blinking instead of solid, it rattles when I get up to a stop sign, sort of stops rattling when I put it in park...And there is a strong smell coming from under the hood. Like maybe what you would smell if you put your face down by the exhaust pipe and smelled it. strong though. Aslo when I am accelerating, the car wants to jerk back and forth when its getting ready to shift. all of this was non existent and now its every time. I will appreciate any help. Thanks
Reply With Quote
  #2  
Old 10-11-2017, 08:20 PM
Senior Member
 
Join Date: Jul 2017
Location: Western NY
Posts: 209
Default

Blinking CEL denotes a misfire, whether spark or a bad fuel injector needs to be determined. how many miles on that 3.5 motor and have you ever had the spark plugs replaced in the last 13 years now? The smell is probably RAW gas going thru the catalytic converter(not good). And with a misfire while driving, it is going to jerk and rattle.
Reply With Quote
  #3  
Old 10-12-2017, 01:50 AM
CHRYSLER TECH's Avatar
Super Moderator
 
Join Date: Mar 2006
Location: Norcross GA
Posts: 7,947
Default

First thing to do is get the codes see what your working with
Reply With Quote
  #4  
Old 10-12-2017, 06:02 PM
Junior Member
Thread Starter
 
Join Date: Dec 2016
Posts: 12
Default

It has about 213k miles. don't know when the spark plugs were changed. Ive had it over 2 years. I did get the codes and there were a lot of em! one had to do with o2 sensor. another was fuel line regulator. camshaft sensor. anymore help would be appreciated. I prefer a diy solution because I don't have more money to dump into this car. Thanks
Reply With Quote
  #5  
Old 10-13-2017, 10:15 AM
CHRYSLER TECH's Avatar
Super Moderator
 
Join Date: Mar 2006
Location: Norcross GA
Posts: 7,947
Default

still need the codes first off
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
cv joints 2008 eng ck lite 2.4 eng metalman3 Chrysler 200 & Sebring 3 03-10-2015 09:47 PM
06 Pacifica "Howls" when you accelerate ppritchard Chrysler Pacifica 8 07-14-2014 07:05 PM
Strong Burning Smell Coming from Rear 2004 Pacifica Chrysler Pacifica 1 04-09-2014 12:32 PM
Strong Smell of gas/fuel inside car Racer 300M, Concorde, LHS, New Yorker 3 12-01-2013 02:08 PM
(2000 chrysler t&c lxi, 3.8 eng) battery light comes on ladyas New Member Area 2 12-13-2009 07:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 09:54 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.