Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

00 T &C problem, someone help please!

  #1  
Old 02-05-2007, 02:55 PM
Thread Starter
Join Date: Feb 2007
Posts: 4
Default 00 T &C problem, someone help please!

Ok, Ive got a '00 Town & Country LX that's having it's issues all of a sudden. First and foremost is my damn washers are frozen. Low wash light is on, been on for a few days at most, fill it up with washer fluid. Lights still on, not pumping any fluid through. Checked the sprayers not clogged. Seems to me the pump may be bad or lines frozen. YesI hear the thepump, so Im guessing its just froze somewhere.Its been a tad cold here, in the -. Any suggestions? How do I UNfreeze this thing, I cant see out my freakin' windows! (Same goes for the rear wiper)

Second. The thing seems to have a surge when running. Usually only happens within the first few miles of driving. Especially does this when coming to a stop. The RPM's will rev up and the van will sort of lunge forward a bit. Im having the dealer check out the idle air control. Any other suggestions?


Any reply post is greatly appreciated.

P.S. Is there a cabin filter on the '00? If so where is it located and how do I change it. The previous owner had dogs and now everytime the defrost is on it smells like wet dog [:'(]

Thanks!!!!
 
  #2  
Old 02-05-2007, 03:58 PM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,114
Default RE: 00 T &C problem, someone help please!

well the washer thing either take it inside and see if it works after it unfreezes or go outside with a hair dryer and find out. There is a checkvalve that maynot work any more near the washer pump.
The surge thing an AIC only controls the air going into the engine at idle not running down the road.
Sounds like either a tranny issue or engine missfire. If u have a cabin filter it will be on the passabger side and u will see a slider where u slide the lock and the filter can be pulled out. If u dont thne u will wont see any place to remove anything. Look in the owners manual for a pic.
 
  #3  
Old 02-05-2007, 09:26 PM
Thread Starter
Join Date: Feb 2007
Posts: 4
Default RE: 00 T &C problem, someone help please!

I will definately have the dealer look at your suggestions. Thanks much. Hopefully tomorrow I can find a warm place to work on the washer pump! Thanks again!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ScAndal
Chrysler Pacifica
3
10-25-2010 07:52 AM
dawnp826
Chrysler 200 & Sebring
10
01-12-2009 09:48 PM
NisCAPE
Chrysler Voyager & Town & Country
3
06-22-2008 04:24 AM
ady
Chrysler Pacifica
4
11-05-2007 12:04 PM
snailtek
Chrysler Pacifica
4
10-24-2007 09:36 PM


Thread Tools
Search this Thread
Quick Reply: 00 T &C problem, someone help please!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.