Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

code 420 2000 t&c

  #1  
Old 06-29-2012, 08:19 PM
Junior Member
Thread Starter
Join Date: Jun 2012
Posts: 2
Smile code 420 2000 t&c

I've just gotten the engine running after correcting a ground issue to the ECM. After running the car a day or so the 420 code poped up. I am a at home mechanic and was wondering what are the most common solutions by posters. After reading the story behind 420, one issue may be a air leak. I noticed earlier when I changed the air filter weeks ago, while the engine is ideling, every minute or so, I hear a large air sucking sound from the drivers side of the engine compartment. After a few seconds it stops, then 1-2 minutes it cycles again with no noticable engine variation. I don't know if this may be related to normal engine operation or not. In addition, I plan to pull and clean the o2 sensors, after inspecting the wiring, No work has been none down there, but who knows. I don't know if they got sooted up when I was working on the ground issue, there was a lot of crankling going on. None of the other possible fault listings seem applicable. The last resort will be my friendly expensive mechanic shop. My diagnostic code reader hasen't cleared the code possibly cause the conditions still exist. Thanks in advance.
 
  #2  
Old 06-29-2012, 09:37 PM
CHRYSLER TECH's Avatar
Super Moderator
Join Date: Mar 2006
Location: Norcross GA
Posts: 8,115
Default

more then likely new converters
 
  #3  
Old 06-30-2012, 12:34 PM
Junior Member
Thread Starter
Join Date: Jun 2012
Posts: 2
Default

The engine is running fine, no lack or acceleration or power. During the"cranking" problems the fuel and ignitions systems were dropprd out bu the ASD relay, posibility of soot was probably an error.
At this pointif I change both o2 sensors it would be cheaper than the shop. With the current heat wave here in New Orleans, I may take the week end off, but I expect to see if any voltage and resistance readings on the sensors indicate a problem.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ttype
Chrysler Pacifica
1
12-09-2014 06:49 PM
flemingetq
General Tech
0
07-26-2011 05:04 PM
chryslerfamilia
General Tech
3
04-01-2011 11:06 AM
cyrone
Chrysler Pacifica
2
03-24-2011 11:39 PM
bubbaisthebest
Chrysler 200 & Sebring
1
02-18-2011 04:22 PM


Thread Tools
Search this Thread
Quick Reply: code 420 2000 t&c


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.