Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

Cold acceleration

  #1  
Old 11-09-2018, 04:48 PM
Junior Member
Thread Starter
Join Date: Aug 2017
Posts: 6
Default Cold acceleration

Hello I have a 2003 T&C 3.3l auto. I brought it back from the dead from a no crank no start. Now in this cold weather when it cold and I accelerate it tries to die. Pump gas and it comes to life. When running down the road I can feel it like missing. Replaced the cam sensor and the crank sensor, and plugs and wires. Once warm seems to do OK. NO CHECK ENGINE LIGHT. THX David
 
  #2  
Old 11-11-2018, 02:57 PM
goggs's Avatar
Senior Member
Join Date: Nov 2012
Location: Dumfries....
Posts: 1,752
Default

Haven't you considered the coolant/engine temp sensor as that's what controls cold running settings.
 
  #3  
Old 11-11-2018, 03:04 PM
Junior Member
Thread Starter
Join Date: Aug 2017
Posts: 6
Default

No I have not. I didn't realize that would cause it to hesitate and die.
 
  #4  
Old 11-12-2018, 02:34 AM
Member
Join Date: Jun 2018
Posts: 58
Default

Have you checked the Idle Air Control Valve as well? That may need a quick clean / replacement.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
davet
Chrysler Voyager & Town & Country
3
05-23-2008 12:17 PM
americanap
300M, Concorde, LHS, New Yorker
0
05-13-2008 08:55 PM
rxlady
Chrysler Pacifica
5
03-19-2008 09:51 PM
64NewYorker
General Tech
4
02-16-2008 07:13 PM
GreenCar
Chrysler Voyager & Town & Country
2
01-12-2006 02:56 PM


Thread Tools
Search this Thread
Quick Reply: Cold acceleration


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.