Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

Faulty speedo in 02 Grand Voyager.

  #1  
Old 11-17-2011, 01:35 PM
Junior Member
Thread Starter
Join Date: Sep 2011
Posts: 11
Default Faulty speedo in 02 Grand Voyager.

The speedometer in my 2002 Grand Voyager suddenly stopped working yesterday and just stayed at 0. All other gauges seem to be working fine.
Want to determine if it could be something minor that I could fix myself before going to the dealer and handing over my first born.

Any tips?
 
  #2  
Old 11-17-2011, 02:16 PM
Senior Member
Join Date: Oct 2011
Location: California
Posts: 722
Default

If you also have shifting problems consider changing the output speed sensor. Try an instrument cluster self test to determine if the speedo itself is good. Here's how:

DIAGNOSIS AND TESTING - SELF-DIAGNOSTICS
The instrument clusters are equipped with a self diagnostic test feature to help identify electronic problems. Prior to any test, perform the Self-Diagnostic Test. The self diagnostic system displays instrument cluster stored fault codes in the odometer display, sweeps the gauges to the calibration points, and bulb checks the warning indicators. When the key is in the ON position with the engine not running, the MIL will remain illuminated for regulatory purposes.

To activate the Self-Diagnostic program:
With the ignition switch in the OFF position, depress the TRIP ODOMETER RESET button.
Continue to hold the TRIP ODOMETER RESET button until Sof and a number (software version number (i.e. Sof 3.2) appears in the odometer window then release the button. If a fault code is present, the cluster will display it in the odometer display. When all fault codes have been displayed, the cluster will display “end” in the odometer display. Refer to the INSTRUMENT CLUSTER DTC'S table to determine what each trouble code means. INSTRUMENT CLUSTER DTC'S DTC DESCRIPTION
100.0 LOOP-BACK FAILURE
100.1 ABS COMMUNICATION FAULT
100.2 BCM COMMUNICATION FAULT
100.3 EATX COMMUNICATION FAULT
100.4 FCM COMMUNICATION FAULT
100.5 ORC COMMUNICATION FAULT
100.6 SBEC/DEC/MCM COMMUNICATION FAULT
200.0 AIRBAG LED SHORT
200.1 AIRBAG LED OPEN
200.2 ABS LED SHORT
200.3 ABS LED OPEN
200.6 EL INVERTER TIME-OUT
200.7 EATX MISMATCH
400.0 EEPROM READ/WRITE FAILURE
400.1 IMPROPER POWER DOWN DETECTED


CALIBRATION TEST
The CLUSTER CALIBRATION table contains the proper calibration points for each gauge. If the gauge pointers are not calibrated, a problem exists in the cluster. If any gauge is out of calibration, replace the cluster.

CLUSTER CALIBRATION SPEEDOMETER CALIBRATION POINT
1 0 MPH (0 KM/H)
2 20 MPH (40 KM/H)
3 60 MPH (100 KM/H)
4 100 MPH (160 KM/H)

TACHOMETER
1 0 RPM
2 1000 RPM
3 3000 RPM
4 6000 RPM
FUEL GAUGE
1 EMPTY
2 1/4 FILLED
3 1/2 FILLED
4 FULL
TEMPERATURE GAUGE
1 COLD
2 1/4
3 3/4
4 HOT


ODOMETER SEGMENT TEST
If a segment in the odometer does not illuminate normally, a problem exists in the display.

ELECTRONIC TRANSMISSION RANGE INDICATOR SEGMENT TEST
If a segment in the transmission range indicator does not illuminate normally, a problem exists in the display. __________________

Thanks to Master Tech at www.dodgeforum.com for posting
 

Last edited by Raptor 07; 11-17-2011 at 02:21 PM.
  #3  
Old 11-17-2011, 03:19 PM
Junior Member
Thread Starter
Join Date: Sep 2011
Posts: 11
Default

Thanks, just ran the diagnostics and it didn't display any error codes.
However it seems to have reset something as the speedo has started functioning again....
 
  #4  
Old 11-18-2011, 02:04 AM
Senior Member
Join Date: Oct 2011
Location: California
Posts: 722
Default

Maybe it just needed waking up. Good news.
 
  #5  
Old 01-23-2012, 05:23 PM
Junior Member
Join Date: Jan 2009
Posts: 6
Default speedo stopped working

Well done
I had same problem and found out how to fix
You have to reset the speedo by pressing in the the button on the speedo and all the light light up on dash and resets itself. Just for future reference.
 
  #6  
Old 01-23-2012, 05:56 PM
Senior Member
Join Date: Oct 2011
Location: California
Posts: 722
Default

Originally Posted by fattylady View Post
Well done
I had same problem and found out how to fix
You have to reset the speedo by pressing in the the button on the speedo and all the light light up on dash and resets itself. Just for future reference.
... as stated in the diagnostics procedure in the previous post.
 

Last edited by Raptor 07; 01-23-2012 at 05:58 PM.
  #7  
Old 12-11-2012, 08:31 AM
Junior Member
Join Date: Feb 2012
Posts: 1
Default

The speedometer in my 2002 Grand Voyager crd suddenly stopped working and just stayed at 0. All other gauges seem to be working fine.
I have 2 codes on my test; 100.5 orc communication fault, 100.4 fcm fault.

What dose FCM AND ORC Mean and how do i fix this problem, can any one help please.
 
  #8  
Old 12-11-2012, 02:04 PM
Senior Member
Join Date: Oct 2011
Location: California
Posts: 722
Default

.....
 

Last edited by Raptor 07; 12-11-2012 at 02:07 PM.
  #9  
Old 12-11-2012, 02:06 PM
Senior Member
Join Date: Oct 2011
Location: California
Posts: 722
Default

.....
 

Last edited by Raptor 07; 12-11-2012 at 02:12 PM.
  #10  
Old 02-26-2014, 09:16 AM
Junior Member
Join Date: Feb 2014
Posts: 8
Default

Hi sorry for jumping in 2 years later but I also have the same problem. Ive done the reset and got no error codes but it hasn't reset the speedo ( it's still not working) The rest of the instrument is working fine. Is it worth just replacing the cluster or do you think it could be donething more?
 

Thread Tools
Search this Thread
Quick Reply: Faulty speedo in 02 Grand Voyager.


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.