Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

HELP PLEASE 97 t/c engine problems

  #1  
Old 08-02-2010, 02:35 AM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 2
Default HELP PLEASE 97 t/c engine problems

i have a 97 t/ c with a 3.8 , 3 years ago my wife drove into a puddle and locked the motor , i replaced but had no power to ign relay , so i bypassed temporarily , and recently i have been loosing my inst cluster , and it has been running bad , i replaced the bcm , fuse panel under dash , computer , engine wiring harness , that fixed the electrical problem with the relay , here is my current problem , starts fine , runs good for about 3 min then no power , bogs down and backfires in the intake when you push on the gas but when you let up the idle returns to normal ... any ideas will be greatly appreciated
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
NESSA1010
Chrysler 200 & Sebring
4
06-06-2013 05:40 PM
settlma
Chrysler Pacifica
2
05-06-2008 09:06 PM
daz911
Chrysler Voyager & Town & Country
0
01-15-2008 11:45 AM
daz911
New Member Area
0
01-15-2008 11:43 AM
tdcobb7
Chrysler Voyager & Town & Country
2
09-11-2007 01:09 PM


Thread Tools
Search this Thread
Quick Reply: HELP PLEASE 97 t/c engine problems


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.