Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

Loss of power and strange whining sound

  #1  
Old 09-24-2010, 03:29 PM
Junior Member
Thread Starter
Join Date: Sep 2010
Posts: 2
Default Loss of power and strange whining sound

Hi all,

My first post, I hope you can help. My Voyager 2.8 lx '05 plate had it's radiator replaced today and after picking the car up I had to make a 300 mile trip. Pretty much straight away whilst the engine was ticking over I noticed a sound from the engine that wasn't the norm, ignored it until I hit the motorway and a whining sound developed and then loss of power. The car seemed to cruise at between 60/70 mph but if more power was needed the whining sound gets louder but no real acceleration.

The AA came out and said it could be the Exhaust Gas Valve and sprayed some Exhaust Gas Recirculation down the air filter area. This didn't help. He ran a diagnostic and nothing came up.

So I guess I would like any input if anyone knows what it could be, (I see the turbo mentioned on a few other forums as well as the EGV) anything else? Also is there anything that the change of radiator could have affected.

Sorry for the long winded post, wanted to give as much info as possible.

Thanks in advance.
 
  #2  
Old 09-26-2010, 04:13 PM
Senior Member
Join Date: May 2008
Location: England
Posts: 541
Default

They could have damaged the intercooler or a turbo hose off. EGR pipes are common to split if you have a exhaust leaking sort of sound. can you record it and post it.
 
  #3  
Old 09-27-2010, 02:23 AM
Junior Member
Thread Starter
Join Date: Sep 2010
Posts: 2
Default

Hi thanks for the advice. It got fixed Saturday. Turned out there was a split pipe coming from the air filter (?) make sense?? Anyhow it was a quick and cheap repair so all good!

Very useful forum, thanks.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Crazyotto
Chrysler Pacifica
2
05-24-2012 07:21 PM
kings322
Chrysler Voyager & Town & Country
15
01-05-2012 05:52 PM
skywalker
New Member Area
0
06-01-2011 12:20 PM
Burekbuster
Past Chrysler Models
1
01-07-2011 03:16 PM
carlovinchic
Chrysler 300, 300C & 300C SRT-8
10
04-14-2010 05:26 PM


Thread Tools
Search this Thread
Quick Reply: Loss of power and strange whining sound


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.