Chrysler Voyager & Town & Country The first and foremost name in minivans leading the class since their inception in the 1980s

Loss of speed uphill while on cruise control

  #1  
Old 07-17-2006, 02:16 AM
Thread Starter
Join Date: Jul 2006
Posts: 2
Default Loss of speed uphill while on cruise control

I have a 1999 T&C with 117000 miles. Van runs fine except when I am on cruise control and going up on any incline. When heading up a slight slope at freeway speeds, on cruise control, vehicle looses speed gradually and the Torque converter does not unlock to downshift so engine can maintain the speed and transmission stays locked in high gear, till I hit about 45 MPH. Then it will maintain 45 MPH till over the hill then gain speed to cruise set speed and and upshift to lock torque converter. It does not matter whether I am going 50 or 75 MPH, the engine does not downshift to maintain speed always on inclines. It is amazing how I loose speed from 75 MPH to 45 MPH while locked on high gear in cruise control without any response from the transmission. However, when going downhill, increase of speed over 3 MPH downshifts transmission to regulate speed so well.

What sensors are not working?

If not using cruise control, vehicle downshifts uphill so well so I doubt it is the transmission.

Thanks
 
  #2  
Old 08-06-2007, 05:59 PM
Join Date: Oct 2006
Location:
Posts: 36
Default RE: Loss of speed uphill while on cruise control

Check your vacuum box (under the battery). This is tied into the vacuum circuit that helps to monitor the engine. Mine was cracked and had the same problems you are mentioning. Mine was replaced under warranty, so I can't give you a price. Not to complicated to replace yourself though. Good Luck.

Fred
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
scrowie190
General Tech
3
02-14-2014 11:15 AM
carsoftampabay
Cirrus & Breeze
1
10-26-2012 11:31 PM
bdj5773
Chrysler Pacifica
4
08-20-2012 11:38 AM
AussieAspen
Chrysler Aspen
2
09-07-2011 08:37 AM
mrorange
Chrysler Voyager & Town & Country
1
06-27-2010 01:06 PM


Thread Tools
Search this Thread
Quick Reply: Loss of speed uphill while on cruise control


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.